Zum Inhalt wechseln


Foto

Q500 Firmwareupdate

yuneec multicopter q500

  • Bitte melde dich an um zu Antworten
39 Antworten in diesem Thema

#31 spacewalker6

spacewalker6
  • 20 Beiträge

Geschrieben 07. Juni 2021 - 20:47

Hallo,

konnte endlich die Flightlogs auf SD Karte speichern. Sind eher Daten vom stehenden Kopter, da die GPS-Verbindung sofort nach Motorstart aussteigt. 

Konnte die Daten hier leider nicht hochladen.

 

Kann da bitte jemand helfen?

 

Gruß Wilfried


Versuchs mal als Foto

Angehängte Datei  P1180560.JPG   268,48K   1 Mal heruntergeladen



#32 h-elsner

h-elsner
  • 992 Beiträge
  • OrtIllertissen
  • 998-V2, Blade 350QX2, Yuneec Q500, Typhoon H, Thunderbird

Geschrieben 07. Juni 2021 - 21:27

Rechtsklick auf FlightLog Verzeichnis > Senden an "ZIP komprimierter Ordner" und diese Zipdatei kann man hier anhängen.Das Bild zeigt nicht allzuviel, nur dass du da noch keinen GPS Fix hast.

 

Gruß HE



#33 spacewalker6

spacewalker6
  • 20 Beiträge

Geschrieben 08. Juni 2021 - 09:48

Guten Morgen,

 

hier die ZIP-Datei mit den FlightLogs.Angehängte Datei  FlightLog2021-06-07.zip   27,09K   10 Mal heruntergeladen



#34 h-elsner

h-elsner
  • 992 Beiträge
  • OrtIllertissen
  • 998-V2, Blade 350QX2, Yuneec Q500, Typhoon H, Thunderbird

Geschrieben 08. Juni 2021 - 15:30

Danke. Damit kann man arbeiten. Es fällt auf, dass der Ablauf immer gleich ist:

- HW Status GPS, Compass ok

- gps_AccH fällt auf einen 'angenehmen' Wert und bleibt auch da

- GPS Fix wird wie erwartet erzielt

- Nach Motorstart, sofort Compass Calibration Error Flag

- nach etwa einer Sekunde wird das HW Flasg für GPS und Compass gelöscht. Damit wird GPS support vom Flight Controller abgeschaltet.

- GPS Daten sind weiterhin vorhanden und auch plausibel, kein großartiges Herumspringen in den Positionsdaten, gps_AccH bleibt weiterhin stabil gut.

 

Das weist ziemlich eindeutig auf den Compasschip hin. Frage: Ist der bei deinem Q500 in der Nase eingebaut (an dem weißen Plastikwinkel) oder hast du einen ganz alten Q500, wo der Compass noch irgendwo vorne am Langestell war?

Da sich das Problem mit Kompasskalibrierung nicht beheben lässt wird wahrscheinlich nur ein HW-Tausch helfen. Vorher jedoch würde ich folgendes überprüfen:

- Ist die mechanische Befestigung in Ordnung - Chip fest eingebaut und richtig ausgerichtet? Wackelt oder verdreht sich nichts? Das Ding ist nur mit einer Messingschraube befestigt.

- Sind die Zuleitungen in Ordnung und ordentlich verdrillt? Die Verdrillung ist nicht nur Schönheit, sondern dient der Störunterdrückung.

- Verbreitete Reperaturmethode: Ziehen und Stecken aller Verbindungen um die Oxidschicht zu brechen.

- Liegen die Stromzuleitungen zu den Motoren bzw. Batterie zu lange zu dicht parallel zu den Signalleitungen zum Kompass? Leichte Änderungen können viel bewirken.

 

Angehängte Datei  Q500_innen04_a.jpg   599,53K   0 Mal heruntergeladen

 

Gruß HE

 

 



#35 spacewalker6

spacewalker6
  • 20 Beiträge

Geschrieben 09. Juni 2021 - 10:07

Hallo HE,

 

hab den Kopter heute wieder geöffnet und die Stecker/Verkabelung für den Kompasschip abgezogen, geprüft und sauber gesteckt.

Ein Kabel am Chip war nicht eindeutig im Stecker.

 

Koptertest danach das erste Mal nach langer Zeit ohne Ausstieg des GPS. Allerdings alles am Boden.

 

Im Anhang nochmal die Flightlogs der letzten beiden Tests.

 

Track 6 ist ohne Probs: Stillstand, Leerlauf, Vollgas

 

Track 7 das selbe mit Probs

 

Kannst du dir die Logs bitte nochmal anschauen.

Wäre überglücklich, wenns jetzt funktioniert.

 

Gruß Wilfried

 

 

Angehängte Dateien



#36 h-elsner

h-elsner
  • 992 Beiträge
  • OrtIllertissen
  • 998-V2, Blade 350QX2, Yuneec Q500, Typhoon H, Thunderbird

Geschrieben 09. Juni 2021 - 12:57

Bei Track 00003 ist der Kompassfehler nach dem Umschalten auf RTH nochmal zu sehen. Dann nicht mehr. Die restlichen Tracks sind unauffällig.

Ich würde jetzt den Kompass kalibrieren und erste Testflüge ohne Kamera machen. Dabei RTH testen.

 

Gruß HE



#37 spacewalker6

spacewalker6
  • 20 Beiträge

Geschrieben 11. Juni 2021 - 12:01

Hallo,

habe jetzt 2 Flüge gemacht.

GPS ist nicht mehr ausgestiegen.

Scheint tatsächlich die Steckverbindung am Kompasschip gewesen zu sein.

Vielen Dank an HE für die sehr kompetente Hilfe und den goldenen Tipp!

 

Allerdings sind zwei weitere Fehler aufgetaucht:

1. Am Sender erscheint während des Flugs oder auch wenn der Sender eingeschaltet auf dem Tisch steht nach einiger Zeit die Warnung "Exiting Flight Data... Are you sure you want to exit".

2. Wenn der Kopter am Boden im Leerlauf steht, gibt er nach einiger Zeit selbstständig Gas und hebt ab (Track15).

 

Gruß Wilfried

Angehängte Dateien



#38 h-elsner

h-elsner
  • 992 Beiträge
  • OrtIllertissen
  • 998-V2, Blade 350QX2, Yuneec Q500, Typhoon H, Thunderbird

Geschrieben 11. Juni 2021 - 13:52

1.) Den Sender würde ich mal auf st10+v01b30c updaten. Dann ein neues Modell anlegen und dieses binden. Vielleicht hilf auch letztes schon.

2.) So richtig kann ich das in den FlightLogs nicht erkennen. Da sind zwar bei Pitch und Roll unerklärliche Spitzen drin, aber die fallen immer mit dem Ausschalten zusammen. Da muss ich mir den zeitlichen Verlauf mal genauer ansehen. Auf jeden fall würde ich den Accelerometer kalibrieren.

 

Gruß HE


  • Bernd Q gefällt das

#39 Bernd Q

Bernd Q
  • 1.940 Beiträge
  • OrtSankt Augustin
  • DJI Mavic 1 Pro
    DJI Mavic Mini
    DJI Osmo Pocket
    DJI Osmo Action
    Yuneec Q500 4K

Geschrieben 18. Juni 2021 - 12:23

Gibt es hier eigentlich neue Erkenntnisse?



#40 spacewalker6

spacewalker6
  • 20 Beiträge

Geschrieben 19. Juni 2021 - 10:52

Hallo,

 

sorry für die späte Statusmeldung.

Aber es gibt seit gestern sehr positive Erkenntnisse. Habe die Tipps von HE umgesetzt und folgende Maßnahmen durchgeführt:

- Accelerometer kalibriert.

- Sender auf st10+v01b30c upgedated.

- Kopter neu angebunden.

 

Am Boden hat der Kopter weder ungewollt abgehoben noch ist die Displaymeldung "Exiting Flight Data... Are you sure you want to exit" erneut aufgetaucht.

Bin sehr zuversichtlich und werde den Vogel morgen im Flug testen.

 

Werde natürlich umgehend berichten.

 

Gruß Wilfried


Hallo zusammen,

 

habe gerade Flugtests mit dem Kopter gemacht.

Absolut alles ok - keine Warnmeldung, GPS bleibt stabil, der Q lässt sich angenehm fliegen.

Bin super happy!

Vielen Dank an alle für die wertvollen Tipps.

Nochmal herzlichen Dank an HE fürs Analysieren der Flightlogs und die Ratschläge zur Problembehebung, auf die ich nie selbst gekommen wäre.

 

Gruß Wilfried


  • Bernd Q und h-elsner gefällt das





Auch mit einem oder mehreren dieser Stichwörter versehen: yuneec, multicopter, q500

Besucher die dieses Thema lesen: 0

Mitglieder: 0, Gäste: 0, unsichtbare Mitglieder: 0