Zum Inhalt wechseln


Foto

FrSky R9 Slim+ mit Flex Firmware: F-Port funktioniert nicht

frsky fernsteuerung taranis f-port fport r9m

  • Bitte melde dich an um zu Antworten
Keine Antworten in diesem Thema

#1 Snox

Snox
  • 64 Beiträge
  • FPV Racer
    Blade 180 CFX
    Blade 130x
    Blade 200srx
    Blade mCpx
    Phantom 3 Advanced

    Spektrum DX6i

Geschrieben 17. Dezember 2019 - 20:18

[gelöst]

 

Hallo,

 

ich habe relativ neu eine Taranis x9d Plus (nicht 2019 Edition, also ohne Access) mit einem (alten - also nicht access) r9m Modul und einem R9 Slim+ Empfänger. Nun wollte ich die neuesten Firmwares flashen und SBus funktioniert soweit. Weil die Flex Firmware ja gut sein soll, habe ich diese danach installiert, wo SBus auch funktioniert. SmartPort habe ich noch nicht getestet. Nun habe ich gesehen, dass es die Flex Firmware auch mit F-Port Support gibt, habe diese dann direkt rauf geladen. Doch bekomme ich einfach kein Signal bei Betaflight. Ich habe TX1, TX3 und TX6 des FCs ausprobiert (mit dem S-Port Kabel), in der Konfiguration F-Port aktiviert und jeweils noch in der Konsole serialrx_halfduplex und serialrx_inverted in allen Kombinationen mit on und off getestet. Nichts funktioniert. 

Ich benutze einen DYS F4 Pro V2 FC

An sich wäre mir F-Port relativ wichtig, weil ich ja sonst 2 UARTs bräuchte, einen fürs Signal und einen für SmartPort oder nicht? Und eigentlich brauche ich die weiteren UARTs. 

 

Ich hoffe, ich habe mein Problem gut beschrieben und ihr könnt mir helfen, sonst einfach nachfragen. 

 

Viele Grüße,

Finn

 

Edit: So, habe es jetzt gerade hinbekommen. Das sieht jetzt so aus, als hätte ich es gar nicht erst alleine versucht, doch ich bin ich seit 3 Tagen dabei und bekomme es nicht hin und habe mich jetzt erst entschieden, auf das Forum zurückzugreifen. Und genau jetzt habe ich es raus... Tut mir echt leid. Vielleicht lernen aber auch andere daraus. 

 

Lösung: Man darf für F-Port (jedenfalls bei mir oder bei dem r9 slim+ Receiver) nicht das S-Port Kabel benutzen, wie es einem immer gesagt wird. Benutzt den RX1 Eingang des receivers und es funktioniert sofort. Einfach bei Betaflight unter Konfiguration F-Port angeben und unter den Port Tab den passenden UART als Seriellen Empfänger markieren und alles läuft. Zumindest was ich getestet habe und das ist bei der Telemetrie die Spannung und an Kanälen die Steuerknüppel. Somit gehe ich davon aus, dass jetzt alles funktioniert. 

Vielleicht könnte ich ja jemanden helfen. 


Bearbeitet von Snox, 17. Dezember 2019 - 20:46.

  • jogi73 gefällt das





Auch mit einem oder mehreren dieser Stichwörter versehen: frsky, fernsteuerung, taranis, f-port, fport, r9m

Besucher die dieses Thema lesen: 0

Mitglieder: 0, Gäste: 0, unsichtbare Mitglieder: 0