Zum Inhalt wechseln


Foto

Pixhawk4 mit Ardupilot-FW fliegt keine Geraden im GPS

apm pixhawk

  • Bitte melde dich an um zu Antworten
4 Antworten in diesem Thema

#1 Titanex7

Titanex7
  • 7 Beiträge

Geschrieben 08. Oktober 2019 - 15:22

Ich fliege einen Skywalker-X8 mit dem Pixhawk4(FMUv5) mit der Pixhawk-FW. Programmiert wird alles über QGrouncontrol am Tablet. Fliegt soweit ganz gut, musste nur die Roll/Pitch-PID-Werte fast auf minimum setzen. GPS Waypoint´s und Kreise fliegt er "mit px4FW" sehr akkurat.
Nun zum Problem, ich möchte die Ardupilot-FW nutzen, unter anderem wegen der AutoTune Funktion. Klappte auch anfangs alles sehr gut, Manual, Stabilized, FBWA, dann AutoTune und auch hier wurden die Standard-PID`s fast halbiert.
Jetzt aber im GPS-Modus (FBWB, Loiter, Waypoint´s über Auto, Circle) fliegt er quasi Schlängellinien. Habe schon mit den L1-Controller-Parametern (NAVL1_PERIOD, NAVL1_DAMPING usw.) justiert, keine Verbesserung.
 
 
Anbei die Log-Datei und bitte um Erleuchtung.
 
Dieser Flug war bei 60km/h, wenn ich auf 40km/h gehe, wird es noch schlimmer, höhere Geschwindigkeiten verbessern den "geraden" Kurs, also der Cicle ist ja keine Gerade ansich, aber sollte eigentlich ein richtiger Kreis sein.

Angehängte Dateien


Bearbeitet von Titanex7, 08. Oktober 2019 - 15:29.


#2 HPAE

HPAE
  • 720 Beiträge
  • 3DR Y6B Pixhawk lite
    Parrot Sequoia

Geschrieben 21. Oktober 2019 - 21:01

Hallo,

bin gerade etwas ratlos. Hast Du Deinem X8 ein Seitenruder gegönnt? Ich dachte immer, das wäre ein Nurflügler. Ich habe einen Zeta fx61 und der fliegt schnurgerade - allerdings ohne Seitenruderfünktion. NAVL1_PERIOD habe ich bei 17, ansonsten alles sehr ähnlich.

BG

Hubertus



#3 Titanex7

Titanex7
  • 7 Beiträge

Geschrieben 21. Oktober 2019 - 21:06

Hab heute mal wieder px4-FW aufgespielt. War dann doch nicht so schnurr geradeaus. Zumindest unter 55km/h, z.B. 44km/h, da werden Kreise und Geraden wabbelig. Liegst es nun vielleicht einfach an der Speed? War mit der Ardupilot-FW auch so, ab 60 km/h war es halbwegs ok.
Hab kein Seitenruder, alles Standard, also wie ein Nuri halt. Ist mein Erster, die brauchen ja wohl recht viel Speed, auch wenn Stall erst bei 25 km/h sein soll.



#4 HPAE

HPAE
  • 720 Beiträge
  • 3DR Y6B Pixhawk lite
    Parrot Sequoia

Geschrieben 21. Oktober 2019 - 21:34

Ich fliege mit dem Zeta im Streckenflug 16 m/s (57 km/h). Wahrscheinlich fliegt er deshalb so gut geradeaus. 

Du hast auf der Pix den Kanal 3 als Seitenruder konfiguriert, deshalb meine Frage. Kann sein, dass das den FC verwirrt.

 

BG



#5 Titanex7

Titanex7
  • 7 Beiträge

Geschrieben 22. Oktober 2019 - 13:09

Achso ok, kann sein, wegen ARM/DISARM-Knüppelstellung? Oder einfach Standard Einstellung.

Eben nochmal Ardupilot mitt 44km/h, da fliegt es totalen Slalom, verbraucht auch ca. 1/3 mehr Ampere.

Sicher irgendwelche TECS Werte oder was weiß ich. Fliege jetzt mal lieber mit der PX4-FW.







Auch mit einem oder mehreren dieser Stichwörter versehen: apm, pixhawk

Besucher die dieses Thema lesen: 0

Mitglieder: 0, Gäste: 0, unsichtbare Mitglieder: 0