Zum Inhalt wechseln


Foto

Verzweiflung: Mamba F405 MK2 + Spektrum SPM4650 !

racequad racer 250

  • Bitte melde dich an um zu Antworten
Eine Antwort in diesem Thema

#1 Stainless

Stainless
  • 19 Beiträge
  • OrtWaltrop
  • Yuneec Q500 4k
    DJI Mavic Pro
    Walkera X350
    Syma x5c

Geschrieben 06. Oktober 2019 - 17:57

Hi @ all,

 

bin dabei mir einen ersten Race Copter zusammenzuschrauben und noch ganz frisch in der Materie.

Komme ursprünglich vom Flächenflug und habe daher noch eine Spektrum DX6. Also warum diese nicht nutzen (dachte ich)?

 

Konfiguration:

 

- Mamba F405 MK2 (Betaflgiht 4.1.0 C5 - Target FURYF4OSD)

- Spektrum SPM 4650 mit SRXL2 Protokoll

- Betaflight 10.5.1

 

Habe den Receiver gemäß Anleitung an GND, 5V + TX6 verlötet. Alles soweit zusammen, verlötet, in Betrieb und gebunden.

Alles was direkt am Stack hängt funktioniert aber:

 

- Meine DX6 wird einfach nicht in Betaflight erkannt!?!?

 

Habe FW 4.1.0RC5 drauf, was wohl auch das SRXL2 Protokoll unterstützt. Wo ich dieses in einem angeblichen Dropdown wählen kann habe ich allerdings noch nirgendwo gesehen.

Nun habe ich auch mal von TX6 auf TX3 umgelötet weil ich dachte vielleicht liegt`s daran!?!? Nööö

 

Habe laut Anleitung auch folgendes ins CLI gespeichert:

 

feature -RSSI_ADC
feature RX_SERIAL
feature TELEMETRY
map TAER1234
set rssi_channel = 0
set serialrx_provider = SRXL2
set serialrx_inverted = OFF
set srxl2_unit_id = 1
set srxl2_baud_fast = ON

 

Aber absolut keine Reaktion von der Funke spührbar!

 

Bin mit meinem Latein am Ende!

Muss ich doch einen anderen Receiver nebst Funke kaufen? :(  :( 

 

Über Hilfe würde ich mich freuen!

 

 

 

 


Ugrade:

 

Habe nun auch die neueste Betaflight Konfigurator Software installiert (10.0.0 RC2)

Hier ist zumindest im Reiter Konfiguration eine Auswahl zum SRXL2 Protokoll möglich.

 

Tut sich aber trotzdem nix!

 

Ich werde irre! Alles ist wie`s soll aber - NIX!

Als hätte ich nur irgendwo vergessen einen Schalter umzulegen!

 

Grrrrr


GELÖST!!  :)  :)

 

Habe schlussendlich wieder umgelötet auf TX6 und in der Betaflight Konfiguration auf UART6 umgestellt!

Tadaaa! Nun funktioniert`s mit meiner Spektrum!

 

Aber auch erst nach allen Udates!

 

- Konfigurator: 10.6.0-RC2

- Target: Betaflight 4.1.0 FURYF4OSD -RC6

 

Und natürlich den entsprechenden Befehlen in der CLI 

 

feature -RSSI_ADC
feature RX_SERIAL
feature TELEMETRY
map TAER1234
set rssi_channel = 0
set serialrx_provider = SRXL2
set serialrx_inverted = OFF
set srxl2_unit_id = 1
set srxl2_baud_fast = ON

 

Nun kann`s an`s Finetuning gehen!


  • jogi73 gefällt das

#2 jogi73

jogi73
  • 3.422 Beiträge
  • OrtBayern - Schwandorf
  • DJI Phantom 1.1.1
    ZMR 250
    Realacc X210
    iFlight IX5 V2

Geschrieben 06. Oktober 2019 - 19:50

Gut das Du das Problem gelöst bekommen hast und Super das Du es hier Dokumentiert hast das es Anderen hilft.







Auch mit einem oder mehreren dieser Stichwörter versehen: racequad, racer, 250

Besucher die dieses Thema lesen: 0

Mitglieder: 0, Gäste: 0, unsichtbare Mitglieder: 0