Zum Inhalt wechseln


Foto

LED am FPV Racer

racequad racer 250

  • Bitte melde dich an um zu Antworten
6 Antworten in diesem Thema

#1 xlschffr

xlschffr
  • 22 Beiträge
  • OrtStuttgarter Raum
  • Armattan Rooster 5'
    GEPRC Sparrow 3'
    iFlight IX3 v2 3'
    Emax Tinyhawk

Geschrieben 16. März 2019 - 22:08

Hallo zusammen,

ich fliege seit einiger Zeit nun Racequads und möchte meine Racer optisch etwas auspimpen  ;D .

Dazu hatte ich zuerst Mateksys 2812 Slim Ledstreifen, die ich auf Banggood gekauft habe.

Als ich diese jedoch an mein (damaligen) Omnibus F4 pro V3 angeschlossen habe, blieben die Lichter aus.

Auch durch zahlreiche Anleitungen wie z.b der von ProjectBlueFalcon, gelang es mir nicht, die Leds zum Leuchten zu bringen.

Irgendwann ging ich davon aus, die Leds sind wohl kaputt und habe deshalb vor einigen Wochen erneut auf Banggood Led

streifen mit WS2812 Leds gekauft. Allerdings bekam ich diese weder an meinem HGLRC F428 noch an meinem Hobbywing F4 G2 nicht zum laufen.

 

Vielleicht kann mir ja einer von euch weiterhelfen  ;) 

Besten Dank im Vorraus!!



#2 kschi

kschi
  • 1.053 Beiträge
  • OrtLippstadt
  • RealACC x210
    RealACC x120
    Q95 Dino
    SpracingF3/F4
    Betaflight

    F540 mit Pixhawk 4

    Taranis x9d
    Fatshark Attitude V2

Geschrieben 17. März 2019 - 17:09

Hi, normalerweise kannst Du die ansteuern, wenn die korrekt verkabelt sind. Wie genau ist denn Dein Aufbau? Wo hast Du die LED's angelötet und welche Einstellungen hast Du im Betaflight eingestellt?


  • xlschffr gefällt das

#3 xlschffr

xlschffr
  • 22 Beiträge
  • OrtStuttgarter Raum
  • Armattan Rooster 5'
    GEPRC Sparrow 3'
    iFlight IX3 v2 3'
    Emax Tinyhawk

Geschrieben 18. März 2019 - 17:40

Hallo,

habe die Leds in "Reihe" also mein Signalkabel vom FC (LED heißt der Pin auf meinem FC) geht an mein Led-Streifen auf DI (Digital Input) und ebenfalls vom FC Plus und Minus.

Die Stromversorgung und das Signalkabel der weiteren habe ich jeweils an den DO (Digital Output) und PLus Minus des vorherigen Streifen angeschlossen.

Genau so wie ProjektblueFalcon () es in seinem Video gemacht hat.

In Betaflight habe ich den LED aktiviert und die Einstellungen so wie im Video gezeigt wird, vorgenommen.

 

Muss ich in der CLI/Kommandozeile in Betaflight vielleicht etwas eingeben ? Habe auf der Betaflight Github Page sowas gesehen aber wusste damit nichts anzufangen.

Besten Gruß 


Bearbeitet von xlschffr, 18. März 2019 - 17:43.


#4 kschi

kschi
  • 1.053 Beiträge
  • OrtLippstadt
  • RealACC x210
    RealACC x120
    Q95 Dino
    SpracingF3/F4
    Betaflight

    F540 mit Pixhawk 4

    Taranis x9d
    Fatshark Attitude V2

Geschrieben 18. März 2019 - 19:35

Hi, hast Du im Betaflight in den EInstellungen den Parameter LED-STRIP  aktiviert? Damit schaltest Du die LED Konfiguration ein.

 

Wenn es nicht geht würde ich erst einmal messen, ob überhaupt 5v an Deinem Anschluss herauskommt. Evtl ist die Anzahl der LED's zu hoch für den 5V Anschluss, probier mal nur einen Streifen anzuschließen.

 

Welchen Controller hast Du genau? Hast Du mal ein Bild?


Bearbeitet von kschi, 18. März 2019 - 19:37.


#5 xlschffr

xlschffr
  • 22 Beiträge
  • OrtStuttgarter Raum
  • Armattan Rooster 5'
    GEPRC Sparrow 3'
    iFlight IX3 v2 3'
    Emax Tinyhawk

Geschrieben 18. März 2019 - 22:21

Hey,
Habe soeben die Lösung gefunden,
Mein Problem war, das ich zwar alles richtig verkabelt habe, aber auf meinem FC auf dem LED Pin eine andere Funktion hinterlegt war.
Nach dem ich diese entfernt habe hat alles funktioniert.

Falls jemand das selbe Problem hat:

Ich habe in der CLI Zeile zunächst 'resource' eingeben. Dann spuckt Betaflight alle Pins aus. Wichtig ist in meinem/unserem Fall die Nummer dahinter. In meinem Fall sah das so aus : LED_STRIP B06.
Als nächstes habe ich 'resource list' eingegeben um mir, die auf die Pins verteilten Funktionen anzeigen zu lassen.
Bei mir stand aber unter B06 anstelle LED_STRIP eine I2C_scl Funktion.
Durch den Befehl 'resource I2C_scl 1 none'
Habe ich diese Funktion entfernt und mit 'save' anschließend gespeichert. Danach setzt Betaflight automatisch LED_STRIP als neue Funktion und somit hat bei mir alles wunderbar funktioniert.

Hier das Video, mit dem ich mein Problem gelöst habe:

#6 kschi

kschi
  • 1.053 Beiträge
  • OrtLippstadt
  • RealACC x210
    RealACC x120
    Q95 Dino
    SpracingF3/F4
    Betaflight

    F540 mit Pixhawk 4

    Taranis x9d
    Fatshark Attitude V2

Geschrieben 18. März 2019 - 22:52

Ah, geht doch. Nur, warum war das LED Pad anders belegt??


  • xlschffr gefällt das

#7 xlschffr

xlschffr
  • 22 Beiträge
  • OrtStuttgarter Raum
  • Armattan Rooster 5'
    GEPRC Sparrow 3'
    iFlight IX3 v2 3'
    Emax Tinyhawk

Geschrieben 02. April 2019 - 12:42

Das weiß ich auch nicht so genau ... Irgendwie kann es sein das ein Pin, der z.b für Led vorgesehen ist, intern mit mehreren Funktionen belegt ist und der FC deshalb nichts ausgibt da er nicht weiß auf welches Signal er hören soll..
Habe die Funktion die auf meinem Led Pin war einfach entfernt, ohne genau zu wissen was sie bewirkt aber bei mir funktioniert trotzdem alles andere weiterhin ohne Probleme





Auch mit einem oder mehreren dieser Stichwörter versehen: racequad, racer, 250

Besucher die dieses Thema lesen: 0

Mitglieder: 0, Gäste: 0, unsichtbare Mitglieder: 0