Zum Inhalt wechseln


Foto

LHI woafly OmniNXT F7 und UBLOX M8N

naze32

  • Bitte melde dich an um zu Antworten
3 Antworten in diesem Thema

#1 waldlatscher

waldlatscher
  • 24 Beiträge
  • OrtSpreewald
  • Multiplex Cockpit SX9
    Eigenbau-Quadro mit NAZA V2
    Eigenbau-Hexa mit Tarot ZYX-M
    Eigenbau-Racer mit Omninxt F7

Geschrieben 10. Februar 2019 - 15:17

Moin,

mein omnibus F7 erkennt kein GPS, also habe ich mir zum Experimentieren ein Omninxt F7 sowie ein UBLOX M8N (für Pixhawk) zugelegt.

Egal ob ich INAV oder Betaflight flashe, es wird nur der Kompaß erkannt. Die Anschlüsse stimmen, hab das UBLOX extra aufgeschraubt.

Ich habe auch alle möglichen Konfigeinstellungen ausprobiert, leider ohne Erfolg. Hat Jemand eine Idee, warum kein GPS erkannt wird ?

Kleiner Tip für Nachahmer: das Board muß richtig mit Strom versorgt werden, nur USB reicht nicht zur Erkennung des UBLOX.

Grüße aus dem Spreewald

Torsten


Bearbeitet von waldlatscher, 10. Februar 2019 - 15:18.


#2 waldlatscher

waldlatscher
  • 24 Beiträge
  • OrtSpreewald
  • Multiplex Cockpit SX9
    Eigenbau-Quadro mit NAZA V2
    Eigenbau-Hexa mit Tarot ZYX-M
    Eigenbau-Racer mit Omninxt F7

Geschrieben 13. März 2019 - 16:22

Moin,

jetzt hatte ich den Verdacht, daß das GPS Modul im Eimer ist. Jedenfalls sagte es am Raspberrypi keinen Mucks, die blaue LED leuchtete ständig.

Okay, hier war wohl die eigene Dämlichkeit am Werk. Ich hab den Raspy mit dem GPS jetzt mal mitten im Hof platziert und was soll ich sagen.

Sofort sind 12 Sats da, die Höhe stimmt und die Koordinaten auch. Das funktioniert jetzt sogar drinnen mit schön langsamen Blinken der LED.

Brauchte das Ding ne Initialzündung ? Schaun mer mal, was das OmniNXT F7 jetzt macht.

Ich halte euch auf dem Laufenden. 

Grüße vom Waldlatscher


Tja, das war wohl nichts. So schön wie alles am Raspberrypi funktioniert, das Omninxt F7 will davon nichts wissen.

Egal ob INAV oder Betaflight, der Kompaß geht, das GPS nicht : So ein Mist. Dabei blinkt die blaue LED langsam, also am Empfang liegt es wohl nicht.

Da ich aber hartnäckig bin, wird das an die Abteilung "Jugend forscht" weitergeleitet. Da bin ich hier das einzige Mitglied in der Umgebung zum Thema ;D

Grüße vom Waldlatscher


Bearbeitet von waldlatscher, 13. März 2019 - 16:33.


#3 654163

654163
  • 297 Beiträge

Geschrieben 13. März 2019 - 16:28

GPS auch richtig an den UART gelötet?

 

GND, 5V und dann RX (FC) an TX (GPS) und TX (FC) an RX (GPS).

TX an TX und RX an RX funktioniert nicht.

 

In Betaflight UBLOX als Protokoll (nicht NMEA) und Auto-Config und Auto-Baud.

Bei den Ports natürlich vorher GPS aktivieren für den richtigen UART.

Funktioniert bei mir an allen Koptern so.


Bearbeitet von connexn, 13. März 2019 - 16:30.

  • HeinzR gefällt das

#4 waldlatscher

waldlatscher
  • 24 Beiträge
  • OrtSpreewald
  • Multiplex Cockpit SX9
    Eigenbau-Quadro mit NAZA V2
    Eigenbau-Hexa mit Tarot ZYX-M
    Eigenbau-Racer mit Omninxt F7

Geschrieben 15. März 2019 - 12:43

Moin,

hab ich alles beachtet, natürlich auch die Kreuzung von TX/RX :-)

Auch UBLOX habe ich eingestellt, obwohl der Raspy NMEA anzeigt. Geht aber beides nicht.

Das Problem ist, nach der Porteinstellung und Abspeichern/reboot sind die Einstellungen wieder weg :-(

Ich habe UART 6 genommen, aber das ist egal, auch an den anderen Ports verschwindet die Einstellung nach dem Speichern wieder.

Ob das am Linux liegt, ich habe keinen Windows-PC ?

In der VirtualBox geht das eher schlecht als recht mit Win7. Da habe ich komischerweise Treiberprobleme. Normal konfig geht, flashen geht nicht.

Naja, jetzt am WE komme ich erstmal zu nichts, das geht dann nächste Woche weiter.

Hier sind noch meine Anschlüsse:

 

VCC 3.3V (rot)

GND (schwarz, dickere Litze)

TXD an RX6 (gelb)

RXD an TX6 (orange)

SCL an SCL1 (grün)

SDA an SDA1 (schwarz, dünnere Litze)

 

Grüße aus dem Spreewald


Bearbeitet von waldlatscher, 15. März 2019 - 12:55.






Auch mit einem oder mehreren dieser Stichwörter versehen: naze32

Besucher die dieses Thema lesen: 0

Mitglieder: 0, Gäste: 0, unsichtbare Mitglieder: 0