Zum Inhalt wechseln


Foto

Naza M V2 - Seltsames Fehlverhalten im GPS-Modus

dja f450 flame wheel quadrocopter multicopter

  • Bitte melde dich an um zu Antworten
25 Antworten in diesem Thema

#1 WilliP

WilliP
  • 33 Beiträge
  • OrtOberzent
  • Eigenbau Quadro 550 mit Naza M, Quanum Nova, F550, Phantom 3 Advanced, 250er Eigenbau, Tricopter, Fly Egg, Vtol CL-84

Geschrieben 10. September 2018 - 21:40

Hallo,

nachdem ich nach einem Empfängerwechsel ein Hard-Reset durchgeführt hatte (die bereits früher eingebrachten Werte bezüglich Modes, Failsafe usw. werden ja dadurch nicht gelöscht) habe ich das trotzdem nochmals alles im PC überprüft und keine Fehler festgestellt. Die IMU und den Kompass habe ich sicherheitshalter neu kalibriert. 

Die ersten beiden Flüge liefen einwandfrei ab. 

Beim dritten Flug in etwa 2 Meter Höhe  im GPS-Modus legte sich der Kopter zur Seite und ließ sich nicht mehr steuern. Er driftete zur Seite weg. Da fiel mir ein, dass ein Kollege aus dieser Situation wieder herauskam, in dem er RTL bzw. Failsafe einschaltete. Da hatte bei mir aber keinen Erfolg. Die Led blinkte weiterhin 3x grün. Nachdem er seitlich hart auf dem Boden aufsetzte und umkippte, gingen die Motore aus - und jetzt kommts - nachdem die Motore aus waren, hat die Led die Failsafefunktion angezeigt - schnelles oranges Blinken. 

Die nochmalige Überprüfung im PC hat ergeben, dass die Failsafe-Position auch tatsächlich geschaltet wird, auch alle anderen Schaltmöglichkeiten zutreffend sind. 

Dieses Mal habe ich noch Glück gehabt; in größerer Höhe wäre das anders gewesen mit dem Schaden, von Personengefährdung ganz zu schweigen. 

Kann jemand sagen, woher dieses Fehlverhalten herrührt?

 

Gruß

Willi

 

NS: In der Stresssituation habe ich leider versäumt, in den Atti-Modus zu schalten. Ich kann also nicht sagen, ob der Fehler damit behoben worden wäre.



#2 Umi

Umi
  • 6.840 Beiträge
  • F650 mit 17" Props
    F550 mit 13"
    16 Motoriger Hexadeca mit 17"
    Blackout Super Spider Hex mit 10"
    GPS Racer, Aurora 68,
    Brushless Hovercraft
    NanoCPX, XK K110, T-Rex 250, T-Rex 600
    Futaba T14SG

Geschrieben 11. September 2018 - 06:21

Eventuell hattest du Probleme mit dem Kompass.
In dem Fall am besten sofort auf ATTI oder Manuell umschalten, sonst geht wahrscheinlich nichts mehr.
  • janschnik gefällt das

#3 WilliP

WilliP
  • 33 Beiträge
  • OrtOberzent
  • Eigenbau Quadro 550 mit Naza M, Quanum Nova, F550, Phantom 3 Advanced, 250er Eigenbau, Tricopter, Fly Egg, Vtol CL-84

Geschrieben 12. September 2018 - 09:50

Hallo Wolfgang,

 

habe inzwischen im Kollegenkreis auch eine solche Aussage bekommen (das mit dem Kompassproblem). Weißt du zufällig, was genau in einem Kompass fehlerhaft funktionieren kann?  Bei meinem fehlerhaften Flug war auf auf einem freien Feld ohne Metall in der Nähe.

 

Gruß

Willi



#4 Umi

Umi
  • 6.840 Beiträge
  • F650 mit 17" Props
    F550 mit 13"
    16 Motoriger Hexadeca mit 17"
    Blackout Super Spider Hex mit 10"
    GPS Racer, Aurora 68,
    Brushless Hovercraft
    NanoCPX, XK K110, T-Rex 250, T-Rex 600
    Futaba T14SG

Geschrieben 12. September 2018 - 10:14

Wenn der Kompass sonst fehlerfrei funktioniert, würde ich meistens auf äußere Einflüsse tippen. (Eventuell eine Ader mit Eisenerz im Boden)
Oder fliegst du an dieser Stelle öfter?

Hast Du die GPS Antenne mit Kompass auf einem Mast sitzen, um Störungen durch die Stromleitungen zu vermeiden?

Ich würde einfach auf einem anderen freien Feld nochmal ne neue Kompasskali durchführen.
Und wenn man bei einem solchen Fehlverhalten des Kopters immer den Mode Schalter zum umschalten auf ATTI im Hinterkopf behält ist das gar nicht so schlimm. ;)

Mir ist auch mal einer Richtung Zaun marschiert, ich habe sofort umgeschaltet und gegengesteuert ... da ist nichts passiert.
Anschließend ne neue Kompasskali gemacht und es ist alles wieder in Ordnung.
  • janschnik gefällt das

#5 HeinzR

HeinzR
  • 2.261 Beiträge
  • OrtBlankenfelde-Mahlow
  • DJI F450/F550, Tarot 680 Pro, Quadframe Six Pro

Geschrieben 12. September 2018 - 10:44

Hallo

Hast Du eine DJI Naza M V2 oder eine ursprüngliche Naza M Lite?

Gruß Heinz

#6 WilliP

WilliP
  • 33 Beiträge
  • OrtOberzent
  • Eigenbau Quadro 550 mit Naza M, Quanum Nova, F550, Phantom 3 Advanced, 250er Eigenbau, Tricopter, Fly Egg, Vtol CL-84

Geschrieben 12. September 2018 - 13:20

Hallo Wolfgang,

 

ich fliege öfter an der gleichen Stelle, weniger, um zu filmen, vielmehr die Grenzen des Copters auszutesten. Tatsächlich hatte ich auch mal mit dem 550er ein ähnliches Fehlverhalten. Da hatte ich dann in einem Hinweis im Assistenten zufällig gelesen, dass man bei einem Empfängerwechsel ein Reboot machen soll (ich hatte da tatsächlich einen Empfänger wegen mehr Kanälen ausgetauscht). Nachdem ich rebootet hatte, ist der Fehler nie wieder aufgetreten. Aber bei meinem jetzigen Problemfall hatte ich ja kurz zuvor rebootet.

Den GPS/Kompass habe ich auf einem Ständer montiert. Die Starkstromleitungen sind auf der Unterseite des Copters. Das einzige was mir als Fehlerquelle einfällt, ist, dass das Kabel vom GPS in mehreren Schlaufen  neben der Naza liegt.

Im Hinterkopf habe ich bei Fehlfunktion jetzt: Atti (und nicht mehr RTH). Danke.

 

@ Heinz:

 

Ist die Naza M V2 mit Original GPS/Kompass.

 

Gruß

Willi



#7 HeinzR

HeinzR
  • 2.261 Beiträge
  • OrtBlankenfelde-Mahlow
  • DJI F450/F550, Tarot 680 Pro, Quadframe Six Pro

Geschrieben 13. September 2018 - 10:41

Hallo

Ich hatte einen ähnlichen Sachverhalt.
Mein Hexacopter wurde in 15m Höhe plötzlich unsteuerbar und schlug dann etwa 50m entfernt in einen Strauch.

Nach Wiederaufbau habe ich dann den Multicopter auf zwei Meter Höhe gebracht.
Etwa 2 Minuten später ist er dann wieder ausgebrochen.
Ich konnte aufgrund der geringen Höhe jedoch ohne erneuten Schaden landen.
Ich habe es dann noch mehrmals wiederholt.

Wenn Du der Ansicht bist, dass es am Kompass liegt, dann solltest Du vielleicht ein preiswertes UBLox M8N GPS Modul kaufen.

Ich hatte damals noch Garantie auf meinen FC und habe ihn zur Prüfung eingeschickt.
Nach vier Wochen kam dann ein neues Teil, FC und GPS Modul, leider ohne Fehlermitteilung.

Gruß Heinz
  • Umi gefällt das

#8 WilliP

WilliP
  • 33 Beiträge
  • OrtOberzent
  • Eigenbau Quadro 550 mit Naza M, Quanum Nova, F550, Phantom 3 Advanced, 250er Eigenbau, Tricopter, Fly Egg, Vtol CL-84

Geschrieben 13. September 2018 - 12:12

Hallo Heinz,

 

Garantie habe ich leider keine mehr, so ein preiswertes Ublox habe ich mir vor ein paar Tagen schon bestellt. Mal sehen, ob der Fehler dann immer noch auftritt.

Bei meiner Recherche vor Ort bin ich auf einen Bericht gestoßen, welcher zu dir passt: gleiches Problem, Garantie noch vorhanden, lt. DJI-Support ist der GPS/Kompass kaputt. Neuen erhalten. Nach einem weiteren Jahr plötzlich wieder das gleiche Problem. Nur ist dann der Copter ohne Wiedersehen entflogen ...

 

Wenn man nur wüsste, welche Situation den Fehler auslöst. DJI scheint sich bedeckt zu halten. Die tauschen halt einfach nur aus ...

 

Gruß

Willi



#9 HeinzR

HeinzR
  • 2.261 Beiträge
  • OrtBlankenfelde-Mahlow
  • DJI F450/F550, Tarot 680 Pro, Quadframe Six Pro

Geschrieben 13. September 2018 - 12:15

Hallo Willi

Sende mal ein Bild von Deinem Copter.

Gruß Heinz

#10 WilliP

WilliP
  • 33 Beiträge
  • OrtOberzent
  • Eigenbau Quadro 550 mit Naza M, Quanum Nova, F550, Phantom 3 Advanced, 250er Eigenbau, Tricopter, Fly Egg, Vtol CL-84

Geschrieben 13. September 2018 - 20:25

siehe Anhang!

Angehängte Dateien



#11 HeinzR

HeinzR
  • 2.261 Beiträge
  • OrtBlankenfelde-Mahlow
  • DJI F450/F550, Tarot 680 Pro, Quadframe Six Pro

Geschrieben 13. September 2018 - 20:46

Hallo Willi

Du hast die ESCs zwischen die Grundplatinen untergebracht, richtig?

Damit hatte ich einmal Schwierigkeiten, weil nach ca. 2 Minuten Flug die ESCs infolge der Erwärmung herunterregelten.
Seitdem baue ich sie nur noch in den Propellerluftstrom.
Es gibt ESCs, die kann man auch in die Rohre einbauen. Sie haben dann meistens auch zusätzliche Kühlrippen.
Bei einem Motorsegler wird durch die Abregelung nur die Leistung etwas herausgenommen.
Mein Racer Multicopter leitete aber einen seitwärts gerichteten unkontrollierbaren "Abflug" ein.
Das muss aber hier nicht zutreffen.

Gruß Heinz

#12 WilliP

WilliP
  • 33 Beiträge
  • OrtOberzent
  • Eigenbau Quadro 550 mit Naza M, Quanum Nova, F550, Phantom 3 Advanced, 250er Eigenbau, Tricopter, Fly Egg, Vtol CL-84

Geschrieben 14. September 2018 - 00:14

Hallo Heinz,

 

ja, die sind zwischen den Rohrenbefestigungsplatten (30 Amp-ESCs). Die liegen allerdings im Fahrtwind, mit dem Copter auf der Stelle stehen tue ich selten. Aber bei Speed fließt ja wesentlich mehr Strom. Ich werde mal nach einem Flug die Temperaturen messen. Wäre tatsächlich eine mögliche Fehlerquelle. Danke für den Hinweis.

 

Gruß

Willi



#13 HeinzR

HeinzR
  • 2.261 Beiträge
  • OrtBlankenfelde-Mahlow
  • DJI F450/F550, Tarot 680 Pro, Quadframe Six Pro

Geschrieben 14. September 2018 - 03:49

Hallo Willi

Die Beschreibungen zu den ESCs geben meistens nicht viel her.

Hier mal eine Beschreibung zu einem ESC in der aufgeführt wird, dass der Regler über "eine Overheat Protection" verfügt.

Gruß Heinz

https://www.gearbest...ASABEgI-gfD_BwE

#14 Nobier

Nobier
  • 1.835 Beiträge
  • Phantom 1
    Phantom 4
    Tarot ZYX-M Octo Eigenbau
    Blade InducTrix
    Racer Eigenbau mit Naze32

Geschrieben 19. September 2018 - 21:41

 Die Led blinkte weiterhin 3x grün.

3x grün blinkt die LED eigentlich nur wenn der Kopter auf dem Startpunkt steht und die Sticks sich nicht in Mittelposition befinden. In der Luft gibt es diese Variante eigentlich nicht.

Schon ein merkwürdiges Verhalten. Leider sind die Bilder recht unscharf das man vom Aufbau auch nicht so richtig auf Fehler erkennen könnte.

Verbaut ist denke ich mal eine PMU, ein iOSD und etwas was darüber gebaut ist, RX?


Bearbeitet von Nobier, 19. September 2018 - 21:44.


#15 WilliP

WilliP
  • 33 Beiträge
  • OrtOberzent
  • Eigenbau Quadro 550 mit Naza M, Quanum Nova, F550, Phantom 3 Advanced, 250er Eigenbau, Tricopter, Fly Egg, Vtol CL-84

Geschrieben 20. September 2018 - 23:50

Hallo,

 

muss mich inzwischen mit 5 verschiedenen Flugcontrols auseinander setzen und komme da manchmal mit den Blinkzeichen etwas durcheinander. Ich bin heute abend nochmal Fliegen gegangen und habe mir das sehr genau angesehen: ich glaube jetzt, dass das ein grünes Doppelblinken ist (und nicht ein Dreifachblinken wie ich ursprünglich mal geschrieben habe). In der Anleitung gibt es auch kein Beispiel für 3fach-Blinken. Ich fliege ja mit der MC-32. Wenn ich da das Gas in Mittelstellung habe, dann blinkt es im GPS-Modus 1x grün. Da ich aber viel mit Gas arbeite, habe ich immer das 2fach-Blinken gesehen, weil der Gasknüppel meistens nicht in der Mittelstellung war. Wieder was dazu gelernt ...

 

Zu der Platzierung der Technik: auf der gleichen Ebene neben der Naza liegen seitlich der Empfänger, obenauf ein Vario, auf der anderen Seite die PMU. Mehr ist nicht verbaut. Die ESC´s liegen eine Etage tiefer. Direkt unter der Naza liegen aber keine ESC´s; die liegen alle außen am Rand der Platine.

Ich habe auch noch mal versucht, den ursprünglich passierten Fehler zu wiederholen. Im GPS-Modus auf Failsafe geschaltet. Auch dieses Mal wieder keine Reaktion, es blinkte 2-fach grün wie früher schon einfach weiter. Es schien mir, dass meine Steuerbewegungen nicht mehr mit dem Copter überein stimmen. Sicherheitshalber auf Atti-Modus geschaltet, wieder zurück auf GPS-Modus und

nochmals Failsafe geschaltet: jetzt funktioniert plötzlich alles, der Copter landet sanft und die Motoren stellen sich ab. In einem anschließenden weiteren Flug konnte ich die Failsafe-Funkton aber nicht mehr auslösen ... Das macht mir dank Wolfgang aber keinen Stress mehr: ich schalte auf Atti-Modus. 

 

@ Heinz: durch Überhitzung scheint der Fehler nicht entstanden zu sein. Die ESC´s werden auch bei Speedflug nur handwarm.

 

Gruß

Willi







Auch mit einem oder mehreren dieser Stichwörter versehen: dja, f450, flame wheel, quadrocopter, multicopter

Besucher die dieses Thema lesen: 0

Mitglieder: 0, Gäste: 0, unsichtbare Mitglieder: 0