Zum Inhalt wechseln


Foto

Kompassprobleme mit APM 2.8.0

apm pixhawk kompass compass

  • Bitte melde dich an um zu Antworten
32 Antworten in diesem Thema

#1 Oli89

Oli89
  • 7 Beiträge

Geschrieben 06. Juli 2018 - 13:35

Hallo zusammen,
nach vielen Tagen der Fehlersuche bin ich auf euch gestoßen und hoffe dass Ihr mir weiterhelfen könnt.
Ich habe mir ein Ferngesteuertes Boot gebaut, welches ich mit einem APM 2.8 automatisch fahren lassen will.

Soweit funktioniert auch alles, nur bekomme ich den Kompass meines APM 2.8 nicht wie gewünscht ausgerichtet (zeigt wechselnd in verschiedene Richtungen).
Ich vermute dass das Problem darin liegt, dass der interne Kompass auch immer ein Signal abgibt.

So wie ich es nun mitbekommen habe, deaktiviert man diesen Kompass durch abziehen des Jumpers. Trotz das ich nun alle Jumper entfernt habe, reagiert mein APM immer noch auf den internen Kompass:-(
Da ich erst dachte dass der APM ggf. defekt ist (kommt aus China) habe ich mir einen 2. besorgt. Hier liegt jedoch leider das selbe Problem vor:-(.
Könnt Ihr mir sagen wie ich hier weiterkomme? Muss ich irgendwelche Leiterbahnen durchtrennen und wenn ja welche?

Über eine Antwort von euch würde ich mich riesig freuen, da ich ehrlich gesagt nicht mehr weiter weiß.

P.s. im Anhang findet Ihr Bilder meiner APM's.

Viele Grüße

OliAngehängte Datei  20180705_195614.jpg   181,29K   1 Mal heruntergeladenAngehängte Datei  20180705_195631.jpg   201,7K   1 Mal heruntergeladenAngehängte Datei  20180705_195801.jpg   208,3K   1 Mal heruntergeladenAngehängte Datei  20180705_195809.jpg   196,96K   2 Mal heruntergeladen



#2 Jorre

Jorre
  • 2 Beiträge

Geschrieben 06. Juli 2018 - 13:48

Ja, da wurden früher (als der APM noch aktuell war) irgendwelche Leiterbahnen durchtrennt - aber welche? Keine Ahnung mehr, sorry...



#3 Chris W.

Chris W.
  • 839 Beiträge
  • OrtHochdahl
  • Lumenier CHARPUX-210 F3 OSD RF2205S 4S, X-Mode Alien 500, Pixhack, MT2216, 4S. Heli: Walkera DF45. Car: 1:8 Nitro, Thundertiger-MTA4, Ofna-Buggy. Speedboot Kl.S14: Hopf-Lightning, Graupner-Magin One.

Geschrieben 06. Juli 2018 - 16:43

Hallo,

als erstes lade dir diese ältere Version vom Mission Planer runter: http://firmware.ardu...nner-1.2.33.msi

Die APM haben ein Problem mit dem neuen MP. Damit den FC komplett rücksetzen danach neu kalibrieren und einstellen.

Deine Firmware muss Version 3.2.1 sein?


Leiterbahn durchtrennen das war mal, nur Jumper abziehen!



#4 Oli89

Oli89
  • 7 Beiträge

Geschrieben 06. Juli 2018 - 18:22

Vielen Dank für eure Antworten.

Ich habe mir den "alten" Mission Planner nun besorgt und versuche mich jetzt an den Einstellungen etc.

Für mich stellt sich nun allerdings die Frage ob der APM hierdurch auch Probleme mit Apps wie Tower oder ähnlichen hat?

Diese sind für mich sehr wichtig, da ich das Boot am See später über das Smartphone programmieren will.

 

Wäre echt super wenn Ihr noch bisschen Licht in mein dunkles Wissen bringen könntet.

 

Viele Grüße

Oli



#5 Chris W.

Chris W.
  • 839 Beiträge
  • OrtHochdahl
  • Lumenier CHARPUX-210 F3 OSD RF2205S 4S, X-Mode Alien 500, Pixhack, MT2216, 4S. Heli: Walkera DF45. Car: 1:8 Nitro, Thundertiger-MTA4, Ofna-Buggy. Speedboot Kl.S14: Hopf-Lightning, Graupner-Magin One.

Geschrieben 06. Juli 2018 - 20:42

Mit Tower hatte ich bisher keine Probleme!

#6 Oli89

Oli89
  • 7 Beiträge

Geschrieben 28. Juli 2018 - 08:44

Hallo,

vielen Dank nochmals für die Tipps.

Nachdem ich nun Wochenlang weiter versucht habe, muss ich mich leider nochmals zu diesem Thema melden:-(

Egal welches Programm ich verwende und egal ob der Jumper auf dem Steckplatz sitzt oder nicht, mein APM reagiert nur auf Drehbewegungen des Bords.

Wenn ich den Kompass drehe passiert hingegen garnichts:-(

 

Hat von euch noch jemand eine Idee wo der Fehler liegen könnte?

 

Viele Grüße

Oli



#7 Chris W.

Chris W.
  • 839 Beiträge
  • OrtHochdahl
  • Lumenier CHARPUX-210 F3 OSD RF2205S 4S, X-Mode Alien 500, Pixhack, MT2216, 4S. Heli: Walkera DF45. Car: 1:8 Nitro, Thundertiger-MTA4, Ofna-Buggy. Speedboot Kl.S14: Hopf-Lightning, Graupner-Magin One.

Geschrieben 28. Juli 2018 - 18:13

Gps/Kompass defekt!
Das andere APM von dir ohne Jumper hat keinen Kompass und reagiert dann auf was?

Bearbeitet von Chris W., 28. Juli 2018 - 18:14.


#8 Oli89

Oli89
  • 7 Beiträge

Geschrieben 28. Juli 2018 - 21:32

Hallo Chris,

vielen Dank für deine Antwort.

 

Bei mir reagieren beider APM's lediglich auf eine Drehung des Bordes Bewegungen am GPS-Modul bleiben unbeachtet.

Da ich jeden APM mit einem GPS inkl. Kompass gekauft habe, habe ich die GPS-Module auch schon untereinander getauscht. 

Das führt jedoch leider auch zu keiner Besserung.

 

Ich verstehe leider noch nicht so ganz, warum ich den Kompass des Bords nicht komplett deaktivieren kann.

Hast du hier noch eine Idee?

 

Viele Grüße

Oli



#9 Chris W.

Chris W.
  • 839 Beiträge
  • OrtHochdahl
  • Lumenier CHARPUX-210 F3 OSD RF2205S 4S, X-Mode Alien 500, Pixhack, MT2216, 4S. Heli: Walkera DF45. Car: 1:8 Nitro, Thundertiger-MTA4, Ofna-Buggy. Speedboot Kl.S14: Hopf-Lightning, Graupner-Magin One.

Geschrieben 28. Juli 2018 - 21:53

Hast du auch alles richtig konfiguriert im Mission Planer? Roll 180 musst du wahrscheinlich einstellen da der Kompass in dem GPS Puck sich auf der Unterseite befindet.
Stell doch mal Fotos ein wo der Kompass konfiguriert wird.

Bearbeitet von Chris W., 28. Juli 2018 - 21:54.


#10 Oli89

Oli89
  • 7 Beiträge

Geschrieben 29. Juli 2018 - 18:16

Hallo Chris,

ich habe schon die verschiedensten Einstellungen versucht.

Leider schaffe ich es nie das der APM auf den externen Kompass zugreift. (Siehe Einstellungen in den Bildern)

Angehängte Datei  Einstellung AHRS.JPG   141,4K   0 Mal heruntergeladenAngehängte Datei  Einstellungen Compass.JPG   49,34K   0 Mal heruntergeladen

 

Wie du in den Bildern sehen kannst dreht sich bei der Einstellung Roll 180 die Einstellung auch auf den Kopf.

Ebenso paßt die Ausrichtung nie zur wahren Stellung des APM. Die Vorausrichtung müsse rechts parallel zur Hauswand unter dem Standpkt. verlaufen.

Einstellung Ausrichtung NONE

Angehängte Datei  Ausrichtung bei None.jpg   606,77K   0 Mal heruntergeladenAngehängte Datei  Einstellung NONE.JPG   77,11K   0 Mal heruntergeladen

Einstellung Ausrichtung ROLL180

Angehängte Datei  Ausrichtung bei Roll 180.JPG   187,1K   0 Mal heruntergeladenAngehängte Datei  Einstellung Roll 180.JPG   75,66K   0 Mal heruntergeladen

 

Kannst du hier einen Fehler finden?

Warum wird der externe Kompass nicht verwendet?

 

Würde mich echt rießig freuen wenn du mich noch weiter helfen könntest.

Weiß langsam echt nicht mehr was ich noch versuchen soll.

 

Viele Grüße

Oli

 



#11 Chris W.

Chris W.
  • 839 Beiträge
  • OrtHochdahl
  • Lumenier CHARPUX-210 F3 OSD RF2205S 4S, X-Mode Alien 500, Pixhack, MT2216, 4S. Heli: Walkera DF45. Car: 1:8 Nitro, Thundertiger-MTA4, Ofna-Buggy. Speedboot Kl.S14: Hopf-Lightning, Graupner-Magin One.

Geschrieben 30. Juli 2018 - 12:14

Das was Du dort eingestellt hast sind nicht die Kompass Einstellungen sonder die Bord Orientation. Steht doch sogar dort!
Damit wird die Einbaulage des Flug-Kontroller eingestellt.

Nimm mal diesen Mission Planer 1.3.35: http://firmware.ardu...nner-1.3.35.msi

Kompass einstellen: http://ardupilot.org..._MainScreen.png

 

In dem Bild ist der PX4 FC beschrieben, Du musst nur auf APM external Kompass klicken!
Wenn dann West und Ost vertauscht sind kommt unter Kompass 1 roll_180 ins Spiel. 

 

Als Anfänger nicht in der Full Parameter List herum spielen!


Bearbeitet von Chris W., 30. Juli 2018 - 12:30.


#12 Oli89

Oli89
  • 7 Beiträge

Geschrieben 30. Juli 2018 - 18:35

Hallo Chris,

ich habe mir jetzt dein von dir empfohlenen Mission Planner runtergeladen.

Leider kann ich hier nur einen Kompass einstellen.

Wie von dir gesagt, habe ich hier APM and Extrenal Compass ausgewählt.

Angehängte Datei  APM and external compass.JPG   79,69K   1 Mal heruntergeladen

 

Mein APM reagiert bei diesen Einstellunge leider dennoch nur auf Bewegungen des Bords, Bewegungen des GPS-Moduls werden ignoriert.

Des weiteren habe ich das Bord nun wieder so ausgerichtet, dass es nach rechts parallel zur Hauswand zeigen sollte.

Es zeigt jedoch wie auf dem Bild zu sehen in eine deutlich versetzte Richtung:(

 

Angehängte Datei  Ausrichtung Compass 30.07.2018.JPG   238,68K   1 Mal heruntergeladen

 

Kannst du dir das erklären?

 

Viele Grüße

Oli



#13 Chris W.

Chris W.
  • 839 Beiträge
  • OrtHochdahl
  • Lumenier CHARPUX-210 F3 OSD RF2205S 4S, X-Mode Alien 500, Pixhack, MT2216, 4S. Heli: Walkera DF45. Car: 1:8 Nitro, Thundertiger-MTA4, Ofna-Buggy. Speedboot Kl.S14: Hopf-Lightning, Graupner-Magin One.

Geschrieben 31. Juli 2018 - 12:49

Das erst was ich sehe ist, das Du den Kompass nicht kalibriert hast. Die x, y, z Werte stehen alle auf Null. Der Horizont steht Kopf. Hast Du die original Werte überall wieder eingetragen und wo hast Du noch dran gestellt.

Am besten machst du einen Factory Reset und fängst noch mal von vorne an.
 


Bearbeitet von Chris W., 31. Juli 2018 - 12:53.


#14 Oli89

Oli89
  • 7 Beiträge

Geschrieben 31. Juli 2018 - 19:38

Hallo Chris,

ich hab jetzt nochmal alles zurückgesetzt und die Kalibrierung durchgeführt.

Die beste Ausrichtung meines Bords sowie die am besten passende Compassrichtung erhalte ich bei der Einstellung Rotation YAW 135.

 

Angehängte Datei  Einstellung 31.07.2018.JPG   90,17K   0 Mal heruntergeladen

 

Leider passt die Voraussrichtung immer noch nicht ganz. Ich habe den Kompass wieder parallel zur Hauswand nach rechta ausgerichtet, aber er weicht immer noch geschätzt 5-10° ab.

Weist du wie ich diese noch einstellen kann?

 

Angehängte Datei  Ausrichtung Compass 31.07.2018.JPG   54,58K   0 Mal heruntergeladen

 

Echt super nett von dir, dass du mir hilfst.

Viele Dank und viele Grüße

Oli

 



#15 Chris W.

Chris W.
  • 839 Beiträge
  • OrtHochdahl
  • Lumenier CHARPUX-210 F3 OSD RF2205S 4S, X-Mode Alien 500, Pixhack, MT2216, 4S. Heli: Walkera DF45. Car: 1:8 Nitro, Thundertiger-MTA4, Ofna-Buggy. Speedboot Kl.S14: Hopf-Lightning, Graupner-Magin One.

Geschrieben 31. Juli 2018 - 19:55

Wenn Du in deiner Wohnung kein GPS Empfang hast stimmt die Ausrichtung sowieso nicht überein.
Stell mal ein Bild von deinem GPS ein!
Ist da für die Ausrichtung kein Pfeil drauf?


Bearbeitet von Chris W., 31. Juli 2018 - 19:56.






Auch mit einem oder mehreren dieser Stichwörter versehen: apm, pixhawk, kompass, compass

Besucher die dieses Thema lesen: 0

Mitglieder: 0, Gäste: 0, unsichtbare Mitglieder: 0