Zum Inhalt wechseln


Foto

Babyhawk Front-Backflip Frage

emax multicopter babyhawk

  • Bitte melde dich an um zu Antworten
Eine Antwort in diesem Thema

#1 jackal7400

jackal7400
  • 1 Beiträge

Geschrieben 29. Mai 2018 - 00:30

Hallo zusammen
 
Bei einem neuen Babyhawk von EMAX - nur geflasht auf die aktuellste Betaflight Firmware - gibt es bei Front- und Backflips das Problem, dass der Flip nicht mit einer horizontalen, sondern verschobenen Achse durchgeführt wird, wie im Video zu sehen.
 
Ich gebe nur Gas und Bewege dann einzig Pitch nach vorne oder hinten. Normalerweise würde sich die Achse in der der Quad sich dreht ja genau horizontal sein.
Bei mir ist sie allerdings um ca 45 Grad verschoben. Er neigt sich also zuerst nach links, macht eine Drehung und steht dann schon wieder korrekt.
 
Weiss jemand, warum die Achse nicht horizontal sein könnte?
Der Gyro ist kalibriert und als das Verhalten schon bestand, testeshalber die ESCs auf aktuellste Firmware aktualisiert. Hat leider nicht geholfen.
 
Abgesehen davon fliegt er sich soweit gut. Mir ist kein Problem mit dem Pitch aufgefallen, bis ich das erste Mal einen Frontflip gemacht habe.
 
In folgenem Video sieht man das Problem: https://www.youtube....h?v=-6HNOPJlCQw (Bei den Front- und Backflips; Video ist 50% der Normalgeschwindigkeit)
 
Hier noch ein paar technische Infos:
 
Betaflight Configurator 10.0.0
Betaflight 3.3.2
 
Hier noch ein diff:
--
# diff
# Betaflight / SPRACINGF3EVO (SPEV) 3.3.2 May 4 2018 / 10:03:50 (64a292f37) MSP API: 1.38
 
feature -RX_PPM
feature RX_SERIAL
feature AIRMODE
feature ANTI_GRAVITY
feature DYNAMIC_FILTER
map TAER1234
serial 2 64 115200 57600 0 115200
aux 0 0 0 1300 1700 0
aux 1 1 1 1300 1700 0
aux 2 13 2 900 1300 0
set gyro_notch1_hz = 0
set gyro_notch2_hz = 0
set serialrx_provider = SBUS
set min_throttle = 1080
set small_angle = 180
set deadband = 2
profile 0
 
set dterm_lowpass_type = PT1
rateprofile 0 
--
 
Und wenn ich ein zweites Mal mit der CLI einlogge, erscheinen am Anfang komische Zeichen. Was hat das zu bedeuten?
CLI Start:
--
| $M> l#èÿg 8
CLI
 
# v
Unknown command, try 'help'
# version
# Betaflight / SPRACINGF3EVO (SPEV) 3.3.2 May 4 2018 / 10:03:50 (64a292f37) MSP API: 1.38 
--

 

Danke für eure Tipps!



#2 Ach-Mett

Ach-Mett
  • 10.816 Beiträge
  • OrtLübecker Bucht
  • WidowMaker 210
    AkKi 270 6S@1500KV
    Blade 380QX Ratte
    LaserQuad 480
    NightHawk X6 Beast
    Rolfi 3200KV 2S 4"
    710er SlowQuad 17"

Geschrieben 30. Mai 2018 - 18:44

Willkommen :)

 

Manche Kopter machen das bei mir auch, andere nicht.

Bei PitchFlips habe ich dann und wann auch noch ungesteuertes Yawing dabei.

Leider kann ich nicht sagen, woran es liegt.

Lässt sich auch irgendwie nicht durch Einstellungen korrigieren.

Eventuell hilft es, die DrehRaten zu verändern.

Das hat es bei mir etwas verbessern können.

Allerdings fliegen die anderen Kopter auch mit den gewünschten Rates sauber.

Ich habe stark unterschiedlich wirkende Antriebe in Verdacht.

Könnte auch sein, dass DrehPunkt und SchwerPunkt zueinander verschoben sind.

 

Dass mit den SonderZeichen bei Version ist mir auch schon aufgefallen.

Auch da weiß ich nicht, warum das so ist.

Eveuntuell handelt es sich um geklonte FC, was aber nur eine Vermutung ist.

 

Leider keine große Hilfe, aber Du bist nicht der Einzige, bei dem sowas auftritt  :-[ 







Auch mit einem oder mehreren dieser Stichwörter versehen: emax, multicopter, babyhawk

Besucher die dieses Thema lesen: 0

Mitglieder: 0, Gäste: 0, unsichtbare Mitglieder: 0