Zum Inhalt wechseln


Foto

CX-20 Sender bindet sporadisch nicht; Bad Gyro Health; 3,3V Regle

cheerson

  • Bitte melde dich an um zu Antworten
3 Antworten in diesem Thema

#1 G-Laden

G-Laden
  • 12 Beiträge
  • Cheerson CX20

Geschrieben 16. Mai 2018 - 21:17

Hallo Freude!

Ich weiß nicht, ob ich mich schon einmal vorgestellt hatte. Mein Name ist Micha, 32 Jahre und komme aus Braunschweig. Ich bin schon einige Jahre Mitglied hier und habe bereits viele Hilfe durch die vorhandenen Themen gefunden. Nun komme ich allerdings nicht weiter und muss einfach mal fragen.
Ich hole erstmal ein bisschen aus:

Meine CX 20 mit apm 2.52 und der 3.21 Costum Firmware hier aus dem Forum flog bis vor kurzem bombastisch gut. Selbst in Dänemark bei Windgeschwindigkeiten (konstant) um die 40km/h parkte sie wie festgenagelt in der Luft.

Neulich erlitt ich dann aber aus purer Blödheit einen harten Absturz.
Ich wollte die Grenze des Akkus austesten um zu wissen ob ich einen längeren Flug über waypoints wagen kann oder lieber nicht.
Nach 18 Minuten und 32 Sekunden fiel sie dann wie ein Stück Altmetall vom Himmel und traf auf dem Feld den einzigen Stein im Umkreis von 5km.........

Lange Rede, kurzer Sinn, zu Bruch gingen 3 Propeller, der Kompassdom, das Landegestell und die Akkuklappe. Im Inneren löste sich das Klebeband vom Apm-kasten, der lag da dann, samt GPS, lose drin.

Ich habe nun alles wieder hergerichtet, das GPS Modul direkt nach oben in die "Kuppel" verlegt und mit Alufolie abgeschirmt.
Als Propeller habe ich die 9450 vom Phantom 2 (Original) gewählt.

Nach der Kalibrierung von Kompass und Gyro ging es zum ersten Probeflug. Da war der Kopter kaum zu kontrollieren, er pendelte stark. Also habe ich den mpu6k Filter nochmal reduziert von zuvor 15 auf jetzt 10Hz und die PID Werte auch etwas zurück genommen. Danach war es schon deutlich besser, so könnte ich - erstmal - damit leben.

1) Nun jedoch bindet sich die Funke zum einen häufig nicht mehr. Im Mission Planner sehe ich auch keine Reaktion auf Steuerbefehle. Erst nach mehrfachem ein- und ausschalten klappt es. Einmal verbunden, hält die Verbindung dann auch ohne Probleme.

2) Das zweite Problem kommt noch dazu, wenn die Funke dann mal da ist, ist kein Arming möglich. Teilweise sehe ich keine Fehler, ab und zu taucht aber die Meldung "Bad Gyro Health" auf.
Habe nun mehrfach kalibriert, aber es ändert sich nichts.
3) Meine Vermutung - der Spannungsregler. Prüfen wollte ich ihn, aber mein Messgerät wurde vom Nachbarn gegrillt.......
Nun habe ich gelesen, dass es sowieso Sinn macht das Teil zu tauschen, habe eh noch ein Paket AMS1117 rumliegen. Das wollte ich vorhin machen, bin jedoch vorerst gescheitert.
Hat da jemand ein Anschlussschema? Im Netz finde ich nur Bilder von APM's die sich vom Aufbau doch unterscheiden :(


So, grob war es das erstmal. Ich hoffe es ist einigermaßen verständlich und es kann mir jemand helfen :)

Danke schonmal und Gruß
Micha



Achja, gerade fiel mir noch ein, dass das piepen beim Akku anschließen anders ist. Es piept jetzt erst 3 mal in gleicher Tonlage, ehe dann die normale Tonfolge abgespielt wird. Hat das einen tieferen Sinn?

#2 PiLoT™

PiLoT™
  • 115 Beiträge
  • OrtSingen ( Bodensee )
  • eigenbau F450 aus 3D Drucker

Geschrieben 17. Mai 2018 - 17:04

Also wegen dem Bad Gyro Fall kannste davon aus gehen das der APM was abbekommen hat.

Was auch erklären würde wenn ein Gyro defekt ist das der dann komisch fliegt bzw zappelt.

Ich hoffe das du weißt wofür ein gyro da ist falls nicht googlen...

Also eine Cam oder sonst was wertvolles würde ich nicht mehr drunter hängen ohne vorher die FC ( APM ) zu tauschen...

 

Grüße



#3 G-Laden

G-Laden
  • 12 Beiträge
  • Cheerson CX20

Geschrieben 17. Mai 2018 - 20:43

Was das Gyro ist und was es tut weiß ich ;)

Ich habe mir heute erstmal ein neues Multimeter zugelegt und den Spannungsregler geprüft, der ist i.O.

Und das Problem mit der Funke scheint auch tiefgreifender zu sein, der Empfänger bindet sich innerhalb weniger Sekunden (LED hört auf zu blinken und leuchtet konstant). Dennoch reagiert die Drohne nicht auf die Bedienung. (im Mission Planner im Punkt RC Kalibrieren bewegt sich nichts).

Hat da jetzt tatsächlich das APM einen abbekommen? :(

Der Horizont bewegt sich allerdings richtig, in alle Richtungen und auch der Kompass zeigt korrekt an.

Bearbeitet von G-Laden, 17. Mai 2018 - 20:50.


#4 bluesoldie

bluesoldie
  • 30 Beiträge
  • OrtSchorndorf Rems-Murr-Kreis
  • Mikrokopter mit GPS und Telemetrie
    diverse BL Tiny Whoops, Boldclash, BetaFPV
    Cheerson CX-23

Geschrieben 14. Juni 2018 - 13:04

Ich würde auf alle Fälle das APM propylaktisch tauschen. Das gebietet das Sicherheitsdenken. Es sind ja einige Unregelmäßigkeiten in deinem System, die eine zentrale Ursachen haben können. Das Gemeine ist, dass einige Funktionen durchaus normal erscheinen können.







Auch mit einem oder mehreren dieser Stichwörter versehen: cheerson

Besucher die dieses Thema lesen: 0

Mitglieder: 0, Gäste: 0, unsichtbare Mitglieder: 0