Zum Inhalt wechseln


Foto

Rodeo 110 Firmware per Cleanflight flashen - Bootloader Error

walkera multicopter fpv firmware cleanflight rodeo 110 bootloader flashen

  • Bitte melde dich an um zu Antworten
7 Antworten in diesem Thema

#1 CopterPilot100

CopterPilot100
  • 6 Beiträge

Geschrieben 10. Februar 2018 - 13:39

Hallo zusammen,

 

bereits mehrmals habe ich versucht, den Rodeo 110 per Cleanflight mit der "Rodeo 110 Cleanflight Firmware.hex" Firmware zu flashen (Da ich anfangs ein Problem mit der Steuerung des Copters hatte).
Dabei habe ich folgende zwei Fehlermeldungen bekommen:
"Communication with bootloader failed" oder "no response from the bootloader, programming: FAILED".

 

Ich nutze Cleanflight Configurator 1.2.4, da bei neueren Versionen wie bei Version 2.1.0 folgender Fehler auftritt:
"Non - Cleanflight/Betaflight firmware is not supported, except for CLI mode."
Zum kontaktieren des Bootloaders hatte ich verschiedene Kabel getestet, aber es erschienen immer die gleichen Fehler.
Als Anleitung habe ich folgendes Video von Walkera verwendet:

 

 

Würde mich sehr über nützliche Tipps freuen ; )

 

Vielen Dank



#2 FlyingGuillotine

FlyingGuillotine
  • 14 Beiträge

Geschrieben 10. Februar 2018 - 20:55

hallo,

hast du auch versucht, den Bootloader zu überbrücken, wie in dem Video gezeigt?

Ich habe meinen Rodeo vor kurzem mit Betaflight geflasht und musste den Bootloader auf jeden Fall nicht überbrücken.

 

Ist bei deinem Rodeo eigtl. noch der IBUS/PPM Switch an der Unterseite vorhanden?



#3 CopterPilot100

CopterPilot100
  • 6 Beiträge

Geschrieben 10. Februar 2018 - 21:13

Hallo FlyingGuillotine,

 

erstmal danke für deine Tipps.

 

Mittlerweile konnte ich den Bootloader kontaktieren und die Original Firmware flashen (http://www.walkera.c...info/id/44.html).

Allerdings funktionieren die Funktionen, welche vorher schon defekt waren, immer noch nicht. Gibt es denn eine andere Firmware für den Rodeo 110, welche nicht von der Originalen Hersteller Website stammt, bzw. mit welcher Firmware hast du denn deinen Rodeo geflasht?

(Da ich nur unter Cleanflight 1.2.4 auf die Daten des Rodeo zugreifen kann. Mit Betaflight/Cleanflight 2.1.0 kann ich nicht einmal den Copter verbinden.)

 

P.s. Wo befindet sich denn der IBUS/PPM Switch denn genau an der Unterseite?

oder: was hat es mit dem Switch auf sich/was bewirkt dieser?

 

Viele Grüße,

CopterPilot100



#4 FlyingGuillotine

FlyingGuillotine
  • 14 Beiträge

Geschrieben 10. Februar 2018 - 21:38

Ich habe mit betaflight 3.2.4 geflasht..

 

zum Switch:

steht eigtl. dran ibus <---> ppm.

Bei den ersten Modellen mit diesem Schalter konnte man noch einen Ibus Empfänger probemlos anschließen.

Bei den aktuellen Rodeo Modellen ist dieser Schalter leider nicht mehr vorhanden.

 

 

Welche Funktionen funktionieren denn nicht?


Bearbeitet von FlyingGuillotine, 10. Februar 2018 - 21:56.


#5 CopterPilot100

CopterPilot100
  • 6 Beiträge

Geschrieben 10. Februar 2018 - 21:55

Also bei mir sind nur diese zwei Aussparungen auf der Unterseite zu sehen (vgl. Anhang).

 

Ich kann den Rodeo 110 nicht mehr von der Devo 7 aus starten/Motoren entsperren. Wenn ich Cleanflight 1.2.4 starte kann ich die verschiedenen Empfangskanäle von dem Rodeo sehen, welche live die Befehle von der Devo 7 übertragen (also sind beide an sich gekoppelt?).

 

Direkt in Cleanflight kann ich allerdings alle vier Motoren ansteuern.

 

Vg

Angehängte Dateien


Bearbeitet von CopterPilot100, 10. Februar 2018 - 22:39.


#6 FlyingGuillotine

FlyingGuillotine
  • 14 Beiträge

Geschrieben 10. Februar 2018 - 22:32

na auf Version 3.2.4

das liegt wohl daran, dass Cleanflight den Befehl Throttle unten links für das Motor Arming nicht kennt.

Ich habe Motor-Arming auf einen Aux Schalter gesetzt gehabt, sowie die Modes.



#7 CopterPilot100

CopterPilot100
  • 6 Beiträge

Geschrieben 11. Februar 2018 - 11:16

Habe es mittlerweile geschafft, den Copter auf die Version 3.0.1 zu flashen. Nun kann ich ihn auch mit Cleanflight 2.1.0 verbinden. (Habe einfach die Rodeo 110 Betaflight Firmware von http://www.walkera.c...info/id/44.html heruntergeladen und geflasht.).

Kannst du mir vielleicht deine Einstellungen als JSON File schicken, damit ich diese über Cleanflight 2.1.0 laden kann?

Hoffentlich ist das die Fehlerquelle.

 

Vg

--------------------


Ok mittlerweile habe ich - mit Hilfe des Videos hier - den Copter mit Betaflight neu flashen können und die wichtigsten Einstellungen finden können. Nun kann ich den Copter ansteuern.
Allerdings bleiben zwei weitere Probleme:

  1. Nur wenn ich den Copter mit dem PC verbinde und Betaflight/Cleanflight starte, kann ich den Copter steuern/leuchtet die rote Status-LED am Heck.
  2. Ich habe alle Parameter 1:1 wie im Video gezeigt eingestellt, allerdings drehen sich die Motoren - wenn ich langsam Schub gebe - unterschiedlich schnell. Deswegen wird ein normaler Flug mit Propellern nicht möglich sein.

Wenn ich bezüglich der zwei Probleme oben noch Bilder von der Konfiguration schicken soll, kann ich das gerne machen ; )

 

P.s.: Soll ich mit diesem neuen Problem hier lieber ein neues Thema aufmachen oder passt es zu dem eigentlichen Thema?


Bearbeitet von CopterPilot100, 11. Februar 2018 - 11:17.


#8 CopterPilot100

CopterPilot100
  • 6 Beiträge

Geschrieben 16. Februar 2018 - 14:33

Update:
Ich habe mir nun einen neuen Rodeo für 130 € über www.fun-and-media.de gekauft. (deutscher Shop mit super Kundenservice).
Den Rodeo konnte ich innerhalb von Sekunden an die Devo 7 binden. Jetzt funktioniert wieder alles so wie es soll.
Auch nochmal vielen Dank an FlyingGuillotine für deine ausführlichen Tipps ; )







Auch mit einem oder mehreren dieser Stichwörter versehen: walkera, multicopter, fpv, firmware, cleanflight, rodeo 110, bootloader, flashen

Besucher die dieses Thema lesen: 0

Mitglieder: 0, Gäste: 0, unsichtbare Mitglieder: 0