Zum Inhalt wechseln


Foto

Naze32 GPS anschließen

naze32 gps

  • Bitte melde dich an um zu Antworten
91 Antworten in diesem Thema

#91 Ralf W.

Ralf W.
  • 393 Beiträge

Geschrieben 21. Oktober 2018 - 08:04

Hallo Ulrich,

 

im LOG sehe ich die Probleme, finde bisher aber keinen Anhaltspunkt für die Ursache. Die Vibrationen Deines Kopters erscheinen mir jetzt problemlos. Der Kompass arbeitet die ganze Zeit und solange der Kopter sich schnell bewegt, passt der vom GPS gemeldete Kurs auch zum von iNAV errechneten Heading. Das sieht alles unverdächtig aus. Ich kann keinen Hardwarefehler (Vibrationen, Gyro, GPS,...) entdecken. 

Trotzdem schlägt PosHold fehl und somit natürlich auch RTH.

 

Ich würde den FC jetzt komplett neu flashen - mit Full Chip Erase! Vorher den CLI-Dump in eine Datei speichern und dann nach dem Flashen alle Werte manuell neu einstellen. Dabei kann man große Blöcke aus dem CLI-Dump zurück kopieren. Das darf man aber nur mit solchen Blöcken tun, wo man ganz sicher ist, dass sich kein Fehler eingeschlichen hat.

 

Wichtig: Für iNAV ab Version 2.0 darf man nur den iNAV Configurator ab Version 2.0 (finale Version, kein Release Candidate) verwenden. Anderenfalls können sich ungewollt CLI-Werte verändern. 

 

Es gibt eine gute Chance, dass der Kopter nach dem frischen Flash auch in PosHold und RTH wieder richtig funktioniert.



#92 dl3ed

dl3ed
  • 46 Beiträge
  • night hawk 280

Geschrieben 22. Oktober 2018 - 06:37

Guten Morgen Ralf,

ich Glaube dahinter gekommen zu sein. Wenn ich den Kopter einschalte (Initialisiere) und keine Fehlermeldung kommt geht alles gut. Es kommt aber mach mal vor das beim Initialisieren des GPS eine Fehlermeldung kommt und in vorm von sehr schnell hintereinander kommenden Piepstönen. Die dann nach ca. 2-4 Sekunden auf hören. Dann werden in der Telemetrie auch erst die Satelliten angezeigt. Wenn das der Fall ist kann er seine Position nicht halten. Ich habe den Verdacht das er mit der Baudrate von 57600 im GPS nicht zurecht kommt. Das ist immer nachvollziehbar. Habe die Baudrate mal auf 19200 reduziert und werde das mal die Tage testen. Habe auch mal ein anderes GPS getestet und des war der gleicht Effekt. Mit der zu hohen Abfragegeschwindigkeit habe ich ja so meine Erfahrung.

Werde Berichten.

 

Gruß Ulrich







Auch mit einem oder mehreren dieser Stichwörter versehen: naze32, gps

Besucher die dieses Thema lesen: 0

Mitglieder: 0, Gäste: 0, unsichtbare Mitglieder: 0