Zum Inhalt wechseln


Foto

Eigenbau hebt nach unsafter Landung nicht mehr richtig ab

eigenbau throttle quad abheben schub

  • Bitte melde dich an um zu Antworten
12 Antworten in diesem Thema

#1 stereolog

stereolog
  • 13 Beiträge
  • OrtMünchen
  • Tarot 650 Sport
    T-Motor MN3110 470KV / 1555 Gemfan
    Pixracer V1.0
    Taranis X9D Plus / X8R

Geschrieben 07. Mai 2017 - 10:23

Hallo zusammen,

 

ich bin neu bei Euch (zumindest als aktives Mitglied), habe mir in der letzten Zeit einen Eigenbau-Quad gebaut und der hatte gestern seinen Jungfernflug.
Auch ich habe selber noch keine Erfahrung mit der Fliegerei, sodass ich Euch gerne von meinen ersten noch nicht sehr erfolgreichen Versuchen berichten möchte, vielleicht kann mir der ein oder andere ja weiterhelfen...

 

Das System:
Rahmen: Tarot 650 Sport

Motoren: T-Motor MN3110 470KV

Propeller: Gemfan 15x5.5

ESCs: Bull TEC 30A, Opto 2S-6S, BLHeli

FC: CRIUS AIOP V2 - MultiWii

GPS: CN-06 V3.0 Ublox Neo-6M

Akku: SLS APL 7000mAh 4S 25C/40C

Funke: FrSky Taranis X9D plus X8R Empfänger

 

Ausgelegt habe ich das System als ruhigen Video-Quad mit 15-20 Min. Flugdauer. Habe dabei eifrig eCalc bemüht und mich am Ende der Preis/Leistung zuliebe für dieses Set entschieden:
https://www.premium-...-regler-15x5-cf

 

ESCs erfolgreich eingelernt, Propeller akribisch ausgewuchtet.

 

Folgende erste Erfahrungen:

Nach erstem zögerlichen Schub geben im Acro-Mode habe ich festgestellt, dass ich mich so nicht abheben traue, weil der Kopter zu unkontrolliert zur Seite tendiert (Untergrund war auch nicht wirklich gut, eine Wiese mit plattgetretenem, eigentlich zu hohem Gras). Im Level-Mode konnte ich dann erfolgreich abheben. Als nächstes wollte ich mich um das Kalibrieren des ACC in der Luft kümmern (war zuvor bereits grob mit Wasserwaage am Boden kalibriert), Ziel: Kopter möglichst ruhig in der Luft halten, Drift durch Trimmschalter ausgleichen, ACC Inflight kalibrieren, landen, neu testen.

Ich war jedoch zu sehr damit beschäftigt, den Kopter ca. auf einer Höhe zu halten und musste immer wieder landen, weil er trotz gleichem, fein dosierten Schub nicht wirklich stabil war. Es hat sich so angefühlt,

als könnte ich mit einem gewissen Schub > 50% abheben, etwas steigen und dann nach kurzer Zeit ging er mit gleichem Schub in leichten Sinkflug über. Schub erhöhen fing ihn dann zwar wieder ab usw. aber ich habe mich sehr schwer getan, ihn trotz Windstille länger als eine halbe Minute in der Luft zu halten. Weniger wegen dem seitlichen Drift als vielmehr wegen der Höhe.

Es kam dabei zu einigen nicht ganz schönen Landungen, bei denen er umkippte, Propeller im Gras, Motoren blockiert - ESCs schalten ab. Also wieder aufgestellt, neu gestartet usw. Irgendwann jedoch war ich
an einem Punkt angekommen, an dem selbst 100% Throttle nicht mehr ausreichend waren, um abheben zu können. Höchstens ein paar cm, aber er wirkte, als wenn er "zu schwer" wäre bzw. die Motoren nicht mehr genügend Schub erzeugen könnten. Auch nicht mit frischen Akku. Was kann passiert sein? Gibt es einen Grund, dass ich nach meinen zahlreichen Kipp-Landungen bzw. -Starts und damit blockierenden Motoren / abschaltenden ESCs die ESCs nochmal neu einlernen müsste? Die Motoren fühlen sich alle unauffällig an, leichtgängig, Propeller sind OK (zum Glück haben sie nur Gras gehäckselt, kein harter Untergrund). Ausrichtung der Motoren/Arme mit Wasserwaage nach den Landungen überprüft, alles soweit ok.

 

Am Ende bin ich mit 2 noch ca. 60% vollen Akkus ziemlich ernüchtert und etwas ratlos wieder heim gefahren.

 

Ich freue mich über Meinungen und Kommentare!

 

Viele Grüße,

Benny
 



#2 Wulf

Wulf
  • 63 Beiträge
  • Ortam Mittelpunkt Bayerns
  • diverse selbstgeschnitzte Quadcopter

Geschrieben 07. Mai 2017 - 13:34

So wie ich dich verstanden habe, drehen die Motoren bei 100% throttle nicht hoch genug.

 

Das kannst du überprüfen indem du jeden Motor einzeln am Gaskanal deines Empfängers anschließt.

Wenn du dann Gas gibst muss der jeweilige Motor zügig bis zur maximalen Drehzahl hochdrehen.

 

Dabei äußerst vorsichtig vorgehen, das ganze erst mal ohne Rotor probieren.

 

Wenn das soweit funktioniert, dann das ganze Spiel wiederholen, aber diesmal mit Last

sprich mit montiertem Rotor. Den Kopter in geeigneter Weise beschweren, damit der

dir nicht um die Ohren fliegt.

 

Dann über die Ergebnisse berichten.



#3 stereolog

stereolog
  • 13 Beiträge
  • OrtMünchen
  • Tarot 650 Sport
    T-Motor MN3110 470KV / 1555 Gemfan
    Pixracer V1.0
    Taranis X9D Plus / X8R

Geschrieben 09. Mai 2017 - 18:23

Ich hab mal alle 4 Motoren einzelnd am Gasweg des Empfängers ohne Propeller laufen lassen. Sie laufen alle von der hörbaren Frequenz her zu einer gleichen Geschwindigkeit hoch. Das einzig auffällige ist, dass sie bei Throttle < 90% hörbar nicht ganz rund laufen, sondern leicht "stottern". Bei vollem Schub merk ich das nicht mehr. Ob das dann auch die maximale Drehzahl ist, weiß ich nicht.

 

Habe in dem Zug eine kleine Beschädigung der Steuerleitung zum ESC an Motor 4 entdeckt. Die Masseleitung wurde etwas gequetscht, sodass die Isolierung an einer Stelle leicht offen ist. Da die anderen Adern jedoch unversehrt sind und

das Ganze im Auslegerrohr verlegt war, sehe ich da jetzt erstmal keine Fehlerquelle.

 

Test mit Rotor steht mangels ausreichend Zeit noch aus.



#4 stereolog

stereolog
  • 13 Beiträge
  • OrtMünchen
  • Tarot 650 Sport
    T-Motor MN3110 470KV / 1555 Gemfan
    Pixracer V1.0
    Taranis X9D Plus / X8R

Geschrieben 13. Mai 2017 - 23:32

So, weitere Untersuchungen haben ergeben, dass ich beim Löten des Goldkontaktsteckers am +Pol zum ESC von Motor 4 nicht ganz aufgepasst habe und

da reichlich Flussmittel zwischen den bananenförmigen, eigentlich leicht drehbaren Teil und den Grundkörper gekommen ist. Dadurch hatte ich spontan Kontaktprobleme,

die ich erst nicht verstanden habe. Was meint ihr, kann das zum beobachteten Verhalten beitragen? Mal eine grobe Vermutung: Durch meinen Faux-Pas hat der eine ESC

bei höheren Drehzahlen nicht mehr genug Saft bekommen und wirkte somit als limitierender Faktor. Wäre das plausibel?


Bearbeitet von stereolog, 13. Mai 2017 - 23:56.


#5 kschi

kschi
  • 776 Beiträge
  • OrtLippstadt
  • RealACC x210 Rahmen
    SpracingF3
    Betaflight

    F540 Rahmen
    Pixhawk 4
    Walkera Gimbal
    Qumox sj4000
    Taranis x9d
    Teensy Telemtrie per x9d und Funk

Geschrieben 14. Mai 2017 - 06:53

Hi,

warum hast Du Dich bei diesem Bomber für eine Multiwii entschieden? Nimm doch lieber eine Naza, bzw eine Pixhawk. Gerade bei der Pix kann man - wenn man tüfteln möchte - sehr viele Paramater konfigurieren.



#6 stereolog

stereolog
  • 13 Beiträge
  • OrtMünchen
  • Tarot 650 Sport
    T-Motor MN3110 470KV / 1555 Gemfan
    Pixracer V1.0
    Taranis X9D Plus / X8R

Geschrieben 14. Mai 2017 - 10:55

Ist zwar etwas Offtopic, aber gut:

Ich habe mich beim Bau an der Bauanleitung von Michael Hogen orientiert (http://quadrocopter-bauanleitung.de). Dort basierte der Sport 650 auf diesem MultiWii FC (damals, als ich bei der Planung und Komponentenbeschaffung war. Mittlerweile Pixhawk). Da ich erstmal Erfahrungen im Bau und Flug sammeln wollte, habe ich mich recht eng an das Tutorial gehalten.
Kurz:
- Firmware verstehen
- Günstig

Ich weiß, dass der MultiWii-FC nicht mehr ganz up-to-date ist, für erste Erfahrungen aber doch sicherlich ausreichend...

 

Status Quo:
- Motoren laufen direkt am Gasweg des Empfängers ohne Propeller alle gleichermaßen minimal unrund, könnte/sollte ich da was am Timing der BLHeli ESCs machen? Da ich keinen Vergleich habe, weiß ich nicht ob das "unrunde" eigentlich ok oder tatsächlich nicht richtig ist

- Motoren verursachen bei Standgas leichte Vibrationen (auch jeder Motor einzelnd) - ohne Propeller!

- Motoren am FC: Wenn ich nur minimal mehr Schub als Standgas gebe, nehmen die Vibrationen schlagartig zu - ohne Propeller!

- Direkt am Empfänger gibt es dieses Phänomen nicht. Ich vermute, die Regelung springt auf die Motorvibrationen an und versucht vergeblich, gegenzuregeln. Dadurch schaukelt sich das Ganze auf.


Bearbeitet von stereolog, 14. Mai 2017 - 10:56.


#7 Wulf

Wulf
  • 63 Beiträge
  • Ortam Mittelpunkt Bayerns
  • diverse selbstgeschnitzte Quadcopter

Geschrieben 14. Mai 2017 - 21:15

Wenn der Motor ohne Propeller läuft sollten keine, bzw. nur sehr geringe Vibrationen auftreten

(mit Propeller natürlich auch nicht). 

 

Ich habe beispielsweise bei einem aktuellen Bau-Projekt EMAX MT3506 650KV verbaut, die laufen 

mit 4s ohne Propeller seidenweich bis zur maximalen Drehzahl hoch.

 

 

Was du noch probieren könntest wäre die Überprüfung ob du die aktuelle BLHeli-Revision

auf den ESC's laufen hast oder evtl. einen älteren SW-Stand.



#8 stereolog

stereolog
  • 13 Beiträge
  • OrtMünchen
  • Tarot 650 Sport
    T-Motor MN3110 470KV / 1555 Gemfan
    Pixracer V1.0
    Taranis X9D Plus / X8R

Geschrieben 19. Mai 2017 - 14:11

Ich habe jetzt per #define DYNBALANCE im MultiWii GUI die Testseite zum Balancieren der Motoren aktiviert und für weitere Analysen verwendet.

 

- FC ist mit dieser Halterung auf dem Rahmen befestigt: http://www.xxl-model...ZA-APM-Multiwii

- Keine Propeller oder Propeller-Mounts montiert

- Für jeden Motor habe ich das selbe Signal von 1580µs vorgegeben, weil ich damit wohl eine Resonsanz des Rahmens treffe und somit die Vibrationen am deutlichsten werden

 

Alle Motoren aus:

Angehängte Datei  AUS.JPG   19,46K   0 Mal heruntergeladen

Nur Motor 1:

Angehängte Datei  M1.JPG   21,33K   0 Mal heruntergeladen

Nur: Motor 2:

Angehängte Datei  M2.JPG   23,05K   0 Mal heruntergeladen

Nur: Motor 3:

Angehängte Datei  M3.JPG   21,49K   0 Mal heruntergeladen

Nur Motor 4:

Angehängte Datei  M4.JPG   21,76K   0 Mal heruntergeladen

Alle Motoren:

Angehängte Datei  ALLE.JPG   26,03K   0 Mal heruntergeladen

 

Leider gibt es keine Skala oder Werte angezeigt, daher will ich darauf hinweisen, dass ich den Maßstab auf 4.5 gesetzt habe und hoffe auf Meinungen / Vergleichsdaten von anderen MultiWii-Benutzern. Ich kann momentan nicht einschätzen, ob diese Vibrationen viel sind oder nicht. Am Rahmen sind sie durch leichtes Kribbeln fühlbar.

 

Dabei ist mir aufgefallen, dass die Motoren trotz gleichzeitig angelernter ESCs und gleichem Signal von 1580µs nicht gleich schnell laufen. Ich habe per Tonhöhenvergleich mal ungefähr diese Frequenzen bei gleicher Ansteuerung ermittelt: M1: 1578 Hz, M2: 1603 Hz, M3: 1587 Hz, M4: 1619 Hz. Ist das normal? Ich meine, diese Drehzahlunterschiede auch in den Kurvenverläufen an Hand der Amplituden sehen zu können.

Nochmal zur Erinnerung:
Das eigentliche Symptom ist, dass ich heftige Oszillationen bekomme (davon hab ich jetzt kein Bild, nicht vergleichbar mit dem obigen Motorsirren), sobald die Regelung des FCs aktiviert wird, also bei mehr als Standgas. Diese Vibrationen werden durch die Regelung erzeugt, die offenbar zu hart reagiert. Wenn ich den FC vom Rahmen löse und z.B. in der Luft halte, dann bekomme ich keine Probleme. Sobald ich den FC samt Entkopplungs-Halterung auch nur auf den Rahmen auflege, geht's wieder los.

Um das Ganze nahezu loszuwerden, müsste ich mit einem Tiefpassfilter bis #define GYRO_LPF_20HZ runtergehen, womit ich die eigentliche Ursache natürlich nicht behebe - und deswegen ist das für mich auch keine zufriedenstellende Lösung.

Ich habe das Ganze auf den Einfluss des PITCH-Reglers zurückführen können. Die Oszillationen entstehen nicht, wenn ich den P-Anteil von 3.3 (standard) auf 1.5 runter nehme. Den D-Anteil muss ich fast auf 0 setzen (Standard: 23), damit sich nichts aufschaukelt.

 

Ist das Anpassen der PID-Werte auf diese Art im Rahmen der üblichen Vorgehensweise "normal" bzw. ist es normal, dass die Standartwerte für manche Fälle derart schlecht sein können, dass es selbst ohne Propeller gleich mal zu solchen Oszillationen kommt? Kann ich aus der Tatsache, dass es der PITCH-Regler ist, irgendwas schließen bzw. die Ursache eingrenzen?

 

Viele Grüße,

Benny

 



#9 kschi

kschi
  • 776 Beiträge
  • OrtLippstadt
  • RealACC x210 Rahmen
    SpracingF3
    Betaflight

    F540 Rahmen
    Pixhawk 4
    Walkera Gimbal
    Qumox sj4000
    Taranis x9d
    Teensy Telemtrie per x9d und Funk

Geschrieben 19. Mai 2017 - 15:32

Hi, evtl verhält sich Dein Kopter so wie meiner damals mit der MultiWii:

 

http://www.kopterfor...-arme-zu-weich/

 

Das Video hab ich grad wieder neu hochgeladen, keine Ahnung, warum das gelöscht war. Aber bloß aufpassen beim evtl. Nachmachen! Auf eigene Gefahr!

 

 

Hab mir dann kurz darauf ne APM und danach ne Pix gekauft. Die Unterschiede sind gravierend!



#10 stereolog

stereolog
  • 13 Beiträge
  • OrtMünchen
  • Tarot 650 Sport
    T-Motor MN3110 470KV / 1555 Gemfan
    Pixracer V1.0
    Taranis X9D Plus / X8R

Geschrieben 19. Mai 2017 - 18:51

Wie sich mein Kopter mit Propellern verhält, weiß ich noch nicht. Und ich will ungern 15'' in der Wohnung anschmeißen :-)
Bei mir gibts ja schon Schwierigkeiten beim Betrieb ohne Propeller. War das bei dir auch ein Thema?



#11 HeinzR

HeinzR
  • 1.895 Beiträge
  • OrtBlankenfelde-Mahlow
  • DJI F450/F550, Tarot 680 Pro, Quadframe Six Pro

Geschrieben 19. Mai 2017 - 19:06

Hallo

Was willst Du denn ohne Propeller testen?

Gruß Heinz

#12 stereolog

stereolog
  • 13 Beiträge
  • OrtMünchen
  • Tarot 650 Sport
    T-Motor MN3110 470KV / 1555 Gemfan
    Pixracer V1.0
    Taranis X9D Plus / X8R

Geschrieben 19. Mai 2017 - 19:27

Verstehe ich dich richtig, dass die ganze Suche keinen Sinn macht ohne Propeller? Ich denke wenn ich schon ohne Propeller vibrationsbedingte Probleme habe, wird es mit Propeller nicht besser...oder?


Bearbeitet von stereolog, 19. Mai 2017 - 19:35.


#13 HeinzR

HeinzR
  • 1.895 Beiträge
  • OrtBlankenfelde-Mahlow
  • DJI F450/F550, Tarot 680 Pro, Quadframe Six Pro

Geschrieben 19. Mai 2017 - 19:42

Hallo

Ich bin der Auffassung, dass man das System nur komplett prüfen kann.

Nach dem ggf. erforderlichen Anlernen der ESCs wird doch nur noch die Laufrichtung der Motoren ohne Propeller geprüft.
Beim Einstellen der Software Parameter sollte man sicherheitshalber die Propeller abbauen.

Gruß Heinz





Auch mit einem oder mehreren dieser Stichwörter versehen: eigenbau, throttle, quad, abheben, schub

Besucher die dieses Thema lesen: 0

Mitglieder: 0, Gäste: 0, unsichtbare Mitglieder: 0