Zum Inhalt wechseln


Foto

Taranis X9D plus Bootloader hängt sich auf

frsky fernsteuerung taranis

  • Bitte melde dich an um zu Antworten
12 Antworten in diesem Thema

#1 redfusion

redfusion
  • 42 Beiträge
  • OrtTrier
  • ZMR250 mit Naze32 rev6

Geschrieben 13. März 2016 - 14:41

Hallo zusammen,

 

ich bin seit kurzem stolzer Besitzer einer nagelneuen Taranis 9XD plus, die mich allerdings vor eine Herausforderung stellt.

 

Grundsätzlich schaffe ich es nicht, dass die Taranis im Bootloader-Modus von meinem PC erkannt wird. Hier mal kurz die Problembeschreibung:

  1. Taranis in Bootloader-Mode starten
  2. Per USB-Kabel mit Rechner verbinden
  3. Windows spielt den "USB-Gerät verbunden"-Sound
  4. Bei den verbundenen Geräten wird die Taranis angezeigt
  5. Ich habe keinen Zugriff auf die Ordner auf der SD-Karte o.Ä.
  6. Nach kurzer Zeit ändert sich die anzeige der verbundenen Geräte: Jetzt steht hier "Treiberfehler"
  7. Nun trenne ich die USB-Verbindung und schalte die Taranis aus -> das geht allerdings nicht
  8. Ich muss die Batterie aus der Fernbedienung rausnehmen, damit sie aus geht

 

Hier noch ein paar Hintergrundinfos:

  • Bootloader bzw. openTX Version ist die 2.1.6 
  • Die Taranis wurde von mir bisher weder geflashed noch sonstwie "bearbeitet", ist also noch im Auslieferungszustand
  • Getestet habe ich das unter Windows 10 und Linux mit ähnlichem Ergebnis
  • Ich habe außerdem verschiedene USB-Kabel getestet und sowohl die Fernbedienung als auch die Rechner mehrmals neu gestartet

 

Was mich jetzt erst mal interessiert, bevor ich mich an das Beheben des Verbindungs-Problems mache: Ist es auch bei anderen schon vorgekommen, dass man die Taranis gar nicht mehr ausschalten kann und die Batterie rausnehmen muss? Das wirkt auf mich nun doch irgendwie sehr nach einem Software-Fehler.

 

Danke für euren Input!



#2 erfindix

erfindix
  • 92 Beiträge
  • OrtKiel
  • DJI F550
    Hexacopter S550
    Quadrocopter S500
    Naza-MV2
    APM2.8
    Taranis X9D

Geschrieben 13. März 2016 - 15:17

Einam den Treiber installieren. Dazu den "Zadig 2.1.0 driver installer for Taranis flashing" herunterladen

Taranis mit dem PC verbinden und das Programm starten

Dann unter Options auf "List all divices" und anschließend den "STM32 Bootloader" auswählen. Bei Driver muss "WinUSB" stehen !

Anschließend auf "Install" klicken.

Müsste dann funktionieren



#3 Gast-Nutzer

Gast-Nutzer

Geschrieben 13. März 2016 - 18:31

@redfusion,

 

genau das gleiche Problem. Ich habe mit Zadig so lange gespielt bis gar nichts mehr ging. Windoof neu installiert und jetzt suche ich für ein Gerät nach dem anderen die passenden Treiber. Bin ja schon froh das ich wieder ins Internet komme. Mein Problem: Dell Laptop aber nur "normale Win 7 CD. Da fehlen allle spezifischen Treiber. Und wie aktualisieren wenn WLNA Treiber auch nicht da und Gerät deaktiviert ???



#4 Don Promillo

Don Promillo
  • 3.702 Beiträge
  • Eine Auflistung meiner Multikopter würde die Bevölkerung verunsichern.

Geschrieben 13. März 2016 - 19:26

Zadig ist sowas von 2014...

Die meisten Probleme entstehen erst dadurch, dass man neue Tarani mit Software aus der Steinzeit zu füttern versucht.

#5 redfusion

redfusion
  • 42 Beiträge
  • OrtTrier
  • ZMR250 mit Naze32 rev6

Geschrieben 13. März 2016 - 20:16

Hello,

 

danke für eure Posts! Zwischenstand:

 

Habe eigentlich schon mehrfach gelesen, dass Zadig nicht erforderlich ist und es (eigentlich) auch so klappen sollte. Habe es aber trotzdem mal ausprobiert und den Treiber augetauscht. Das hat allerdings nichts gebracht, das Problem besteht immer noch genau so wie vorher.

 

Außerdem habe ich festgestellt dass der Bootloader sich nicht aufhängt wenn man die USB-Verbindung erst über Windows trennt.  ;)

 

Ich habe es jetzt auf einem Windows 10, einem Linux und einem Windows XP-System getestet - bei allen Systemen war das Verhalten ungefähr gleich. Bei XP hat er beim Einstecken ein Massenspeichergerät entdeckt, beim Installieren der Treiber ist dann aber ein Fehler aufgetreten und ich konnte wieder nicht drauf zugreifen.

 

Ist das normal? Es könnte ja sein, dass mein Modell defekt ist. Dass es wirklich auf so unterschiedlichen Systemn nicht funktioniert ist ja schon sehr merkwürdig.

 

Viele Grüße

 

@Baufuchs: Verdammt, das ist mies! Viel Erfolg beim frickeln  :)



#6 C.P.

C.P.
  • 492 Beiträge

Geschrieben 14. März 2016 - 01:26

Der Bootloader 2.1.6 macht manchmal Probleme. Probier mal OpenTx 2.1.7 in Companion zusammenstellen, auf der Festplatte speichern, umbenennen (Namen kürzen), per Hand auf die SD-Karte kopieren, Taranis normal starten, ins SD-Verzeichnis, die 2.1.7 aufrufen und den Bootloader updaten, die Taranis im Bootloadermodus starten und 2.1.7 installieren.

Zadig brauch man nur noch, wenn man eine uralt Taranis ohne Bootloader hat, ansonsten sollte man lieber die Finger davon lassen, da man sich damit noch mehr kaputt machen kann.

#7 bind.ing

bind.ing
  • 3.009 Beiträge
  • 210er
    TBS Discovery

Geschrieben 14. März 2016 - 20:54

Man kann auch die Firmware über den Companion lasen einfach Taranis ausgeschaltet per USB anstecken, und im Companion auf Firmware flash klicken und die richtige Datei auswählen.

 

Ich musste (hab ich zufällig heute gemacht, wegen diesem Video:

 

 

vl hilft es auch ein wenig) heute gemacht. Beim ersten mal funktionierte es nicht, als ich die Zadig Treiber installiert hatte, funktionierte es. Bootloader wie Firmware sind 2.1.7

 

LG


Bearbeitet von bind.ing, 14. März 2016 - 20:55.


#8 Gast-Nutzer

Gast-Nutzer

Geschrieben 20. März 2016 - 16:42

Der Bootloader 2.1.6 macht manchmal Probleme. Probier mal OpenTx 2.1.7 in Companion zusammenstellen, auf der Festplatte speichern, umbenennen (Namen kürzen), per Hand auf die SD-Karte kopieren, Taranis normal starten, ins SD-Verzeichnis, die 2.1.7 aufrufen und den Bootloader updaten, die Taranis im Bootloadermodus starten und 2.1.7 installieren.

Zadig brauch man nur noch, wenn man eine uralt Taranis ohne Bootloader hat, ansonsten sollte man lieber die Finger davon lassen, da man sich damit noch mehr kaputt machen kann.

 

Jepp, endlich. Es lag tatsäcjlich an der alten Bootloader Version. Ich bin Deiner Anweisung gefolgt und prompt hatte ich die beiden Laufwerke. Und nachdem ich beide unter Windoof ausgeworfen hatte konnte ich die Taranis auch wieder sauber herunterfahren.

Danke!



#9 HenryS

HenryS
  • 18 Beiträge

Geschrieben 13. Mai 2020 - 18:52

Hallo allerseits!

 

Ich hole dieses Thema aus aktuellem Problem wieder hoch ...

Kennt jemand das Problem:
Die X9D+ (Bootloader und FW sind auf 2.3.7) mit dem Mac Book (OpnTX 2.3) verbinden funktioniert nicht.
Es kommt zwar "USB connected", aber das war's dann auch.
Keine 2 Laufwerke (Taranis + SD), nichts.
Zieht man das USB-Kabel ab, bleibt die Meldung "USB connected".
Der Sender hängt sich auf und kann nicht mehr abgeschaltet werden.
Es hilft nurmehr Akku abziehen.

Ein Nachbarjunge hat sich den Sender auf Willhaben gekauft.
Lt. Verkäufer funktionierte der Sender bei ihm tadellos ...???

Die Lötstellen des USB-Anschlusses sehen sauber und ok aus.
Die Flachkabel hab ich auch schon neu gesteckt.
Keine Änderung :(
Sonst funktioniert der Sender.
Hinweis: meine X9E (ebenfalls 2.3.7) funktioniert problemlos mit dem USB!

Hat jemand eine Idee?



#10 Pehaha

Pehaha
  • 2.226 Beiträge
  • OrtHagen / Westf.
  • DJI Phantom 1.1, Phantom 2 ,Parrot Disco, und vielen Flächenmodelle

Geschrieben 13. Mai 2020 - 21:19

Es gibt eine Fehlbedienung , die diesen Fehler auslöst

 

Helfen kann dann nur noch Fa. Engel.

 

Melde dich im Taranis Forum der Fa. Engel an.

 

https://frsky-forum.de/

 

Dort wird dir geholfen.



#11 HenryS

HenryS
  • 18 Beiträge

Geschrieben 14. Mai 2020 - 15:55

Melde dich im Taranis Forum der Fa. Engel an.

 

https://frsky-forum.de/

 

Dort wird dir geholfen.

 

 

Ok, danke!


Bearbeitet von HenryS, 14. Mai 2020 - 15:55.


#12 HenryS

HenryS
  • 18 Beiträge

Geschrieben 15. Mai 2020 - 19:03

Danke für den Hinweis mit dem frsky-Forum!

Es wurde mir (und damit dem Nachbarbuben) geholfen!

 

Die SD-Karte war schuld daran, obwohl sie direkt an den Mac angeschlossen, funktioniert hat.

Eine neue verwendet - alles ok.

Kuriose Geschichte!

 

Gruß Heinz



#13 Pehaha

Pehaha
  • 2.226 Beiträge
  • OrtHagen / Westf.
  • DJI Phantom 1.1, Phantom 2 ,Parrot Disco, und vielen Flächenmodelle

Geschrieben 15. Mai 2020 - 19:25

Henry , dort laufen derart viele Freaks rum, und das Engel Team ist auch hoch motiviert.







Auch mit einem oder mehreren dieser Stichwörter versehen: frsky, fernsteuerung, taranis

Besucher die dieses Thema lesen: 0

Mitglieder: 0, Gäste: 0, unsichtbare Mitglieder: 0